Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Jan 2001
    Location
    Sacramento, California, USA
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts

    'Record is Deleted' error (Access97(SR2))

    I have a database that is copied to a server each morning before staff arrive in the office. When opened on the server by anyone (including me), it returns a "Record is Deleted" error. If the HELP button is used, the following is provided:

    Record is Deleted (Error 3167)
    "You referred to a record that you deleted or that another user in a multiuser environment deleted. Move to another record, and then try the operation again."

    Despite the error message, after clicking "OK", the users can do all the normal inquries that the forms provide to them, but if you use the F11 key to open the database window, all the objects are missing (blank screens for tables, queries,f orms, etc).

    Problem is, it will return this error message even if I am the only one in the database, prior to any staff arriving in the office, so I know it isn't a conflict among users. And it will open fine on my local hard drive copy. There are no passwords or security associated with this database, and it provides information lookup rather than data entry.

    I am not very advanced in using Access, just now starting to actually use/write code instead of relying on macros. Any help/suggestions would be appreciated. <img src=/S/headthrob.gif border=0 alt=headthrob width=15 height=15>

  2. #2
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: 'Record is Deleted' error (Access97(SR2))

    You say you get an error when you open the database? This means you are immediately going to a form. What is going on with this form? That is, what is its recordsource, does it do anything in the load or open events?
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  3. #3
    Lounger
    Join Date
    Jan 2001
    Location
    Sacramento, California, USA
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'Record is Deleted' error (Access97(SR2))

    Thank you very much Mark, you pointed me in the right direction to fix my problem. I was using Roger J. Carlson's (Roger's Access Library) forms to log users out of a databse to perform maintenance. But I had tweaked the Timer event interval on the form to 1000, which was creating the problem (I assume it needs a few seconds to resolve). Once I set the timer event interval to 20000, problem solved.

    Thanks again Mark; you lounge moderators are the BEST!
    <img src=/S/clapping.gif border=0 alt=clapping width=19 height=23>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •