Results 1 to 3 of 3

Thread: Acces 97

  1. #1

    Acces 97

    I have a database ruuning on a network - 2 PC running win95 and two arerunning win98. All have SR2 office 97. I have written code that looks through the recordset for a particular date thta has been entered on a form. The 95 PCs work fine but the 98 PCs bring the wrong date through. When steeping through the code The 95 pC bring the date from the form as 16/02/2002 but the 98 PC show it as 16/02/02 and the code fails to find the record. Below is some of the code
    Dim checkdateavail As Date
    Dim dbs As Database
    Dim rstWedDates As Recordset

    If IsNull(Me![PencilDate]) Then
    Exit Sub
    End If

    checkdateavail = MakeUSDate(Me![PencilDate])

    What can I do to make the date come through correctly? All regional settings are set to British(United Kindom).
    Thanks for any help, perhaps I can now stop banging my head against a hard brick!

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Sacramento, California, USA
    Thanked 1 Time in 1 Post

    Re: Acces 97

    What you need to do is set the system date on your 98 PCs to display a 4-digit year by default. You could write some code to do this in the startup routine of your database using the GetOption and SetOption methods. If you want to do it manually, bring up the Tools-->Options dialog, click the General tab, and in the Use 4-digit year formatting group, check one of the boxes. I enforce it on all my databases for simplicity.

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Brisbane, Queensland, Australia
    Thanked 1 Time in 1 Post

    Re: Acces 97

    Or set the system date format in control panel. go to control panel/regional settings and on the Date tab set short date to d/mm/yyyy. Also look at the settings for long date while you are there.

    WARNING. This setting will affect all (or most) applications.
    David Grugeon
    Brisbane Australia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts