Results 1 to 8 of 8
  1. #1
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Yilgarn region of Toronto, Ontario
    Posts
    5,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    'keep with next' in table (Word97SR2)

    (I tried to insert a SEARCH for y'all here, but it screws up, so I'll post THAT query in Lounge Matters. In the meantime you can see what i have previously searched by clicking the SEARCH button and using "keep with next" table and the AND option. That should find all posts that contain the phrase "keep with next" AND the word "table")


    I can't get it all together (again!)

    I have a 3-column table, the sole occupant of a document. (please see attached PKZipped snapshot in BMP format)

    I select the entire document (Ctrl-A), and clear all local formatting (Ctrl-Space) and apply Normal Style (Shift-Ctrl-N).

    Looks Good.

    Except for the third column, foot of second page, start of third page. The table cell is split over the boundary between pages 2 and 3.


    Odd, I think, I'll check the "Keep Lines Together" setting.


    The table cell contains Four paragraphs. The paragraphs appears as 2, 2, 3 and 1-line paragraphs. Each of the paragraphs is much larger than the cells to the left. (O.K. It's a resume. Column 1 holds the date range, column 2 the language, and column 3 - my problem area - a description of what I did during that period).


    As a result of my mass-formatting (above), every paragraph, every cell, every row shows the settings:
    Widow-on,
    Together-on,
    Next-off,
    Break-off.

    I select the first three paragraphs of the offending cell (as shown in the snapshot). All three paragraph marks are selected. I turn KeepWithNext on for the selected paragraphs (locally, as in Format, Paragraph, rather than Format, Style, Modify ...)

    The fourth paragraph still bleeds over into the next page.


    Every paragraph setting appears OK.



    So why, then, does my table cell split across the page boundary?
    Attached Files Attached Files

  2. #2
    KTYorke
    Guest

    Re: 'keep with next' in table (Word97SR2)

    by no means am I going to try to answer the whys or wherefores... but I can suggest a solution.

    Select the whole row... click in the left margin to choose the entire row and it's little mark at the end so it's all highlighted, then choose Format>Paragraph>Line and Page Breaks> Keep with Next>OK

    That should work. If someone knows of a way to make the KWN feature to work inside a single cell, as you have tried, I'd love to know how!
    have fun

  3. #3
    New Lounger
    Join Date
    Nov 2001
    Location
    Santa Ana, California, USA
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'keep with next' in table (Word97SR2)

    Word97 will not allow you to apply the KWN feature to a "single cell" it needs the little mark at the end of the row to be selected as you suggested...that is the table's equivalent to the "paragraph mark." HOWEVER, we have been able to "trick" the table into accepting the KWN feature by writing a specific style to be used in our tables which has the KWN feature turned on in the style. This does, however, create the opposite problem when the table grows longer than one page...all the rows want to remain together.

    In short, you may think about writing a style with KWN feature turned on.

    <img src=/S/brainwash.gif border=0 alt=brainwash width=15 height=15> Kenneth

  4. #4
    KTYorke
    Guest

    Re: 'keep with next' in table (Word97SR2)

    <img src=/S/hmmn.gif border=0 alt=hmmn width=15 height=15> I've done this with the styles for my tables... BUT I had the "Keep Lines Together" and "Window/Orphan Control" turned on in the style. (I'm also using Word97) The KLT and WOC still leaves some lines orphaned or parts of a paragraph on another page when inside a cell. I think I stopped just short of the KWN feature because of the problem you described.
    thanks!
    have fun

  5. #5
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Yilgarn region of Toronto, Ontario
    Posts
    5,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'keep with next' in table (Word97SR2)

    You guys are gonna KILL me, I know, but .....

    1) I can't reproduce the problem and
    2) I didn't keep a copy of the document.

    I "fixed" the problem by changing the style to be 10pt (was 12pt) and space before/after to be 6/6 (was 3/3). Since it's a three page document, it didn't take a lot of checking to make sure that no cells were split.

    Well, after seeing your suggestion (and I thought I'd tried formatting the entire row) I reloaded the doc, changed the style back to 12pt and 3/3 and everything looks fine! That cell does NOT split across the page boundary. ??, ??!!???, and !!??!!@???

    You may wonder, how is a brillaint good-looking Aussie to check that it really is working the way it should? Well, I opened up the header and used Ctrl-[ and Ctrl-] to ring a few changes on an empty paragraph within the header. I figured that would change the text area in small increments, sufficient to trigger the problem.

    Nope! There came a point when the entire row (including my offending cell) slid to the next page.


    My current theory is that had I two hours ago, just saved and re-opened the document (or maybe exited Word, then reloaded the document) my KeepWithNext would have taken.

    Maybe Word doesn't communicate too well between the formatting at the time it is applied and the display as it was before formatting.


    If I can dream up a way to trigger the problem, I'll attach a sample document in PKZip format for anyone to essay.

  6. #6
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Yilgarn region of Toronto, Ontario
    Posts
    5,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'keep with next' in table (Word97SR2)

    In the attached document, for the rows 10, 11 and 12, I have set to "off" ( choose Format, Paragraph, ...) Widow/orphan, Keep Lines Together, Keep With Next, Page Break before.

    In row 11, Para3a slips over to the next page.

    Traps for young players: I show paragraph marks (Tools, Options, View, Paragraph marks) and note that if I click the mouse in the cell to the right of the Para2a paragraph mark, then that paragraph mark is NOT selected.

    If I click immediately to the left of "P" in Para3a of row 11 and drag upwards, I do select the paragraph mark for Para2a.

    With both Para1a and Para2a and their trailing paragraph marks selected, I choose Format, Paragraph, Keep With Next. This (KWN) is the only one of four check boxes selected. I confirm - and nothing changes. Para3a is still on the next page.

    I exit Word, then reload the document - nothing changes.

    I select the entire row (choose Table, Select Row) and Format, Paragraph, and note that keep With Next is ambivalent. I turn it on, confirm, and BINGO! Just as KTYorke predicted in her first response, my paragraphs 1a, 2a and 3a now appear on the same page.


    Now I don't know what happened before. I felt sure that I had selected the entire row, with no effect.
    Attached Files Attached Files

  7. #7
    Lounger
    Join Date
    Mar 2001
    Location
    PA
    Posts
    29
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'keep with next' in table (Word97SR2)

    Maybe I am misunderstanding the problem, but it looks to me as if you want to prevent rows in your table from "breaking" at a page break. In other words you want to avoid having part of a row on one page and the rest of the row on the next page.
    IF that's what you want, the KWN is not going to do it for you inside a table. To keep rows intact within a table you need to go to Table|Select Table. Then click on Cell Height and Width in the Table menu. You want to UNCHECK the line that says Allow row to break across pages. This will work without regard to what KWN does, as long as you are in a table. I am also on Word 97/SR2, so this should work for you.

  8. #8
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Toronto, Ontario, Canada
    Posts
    230
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'keep with next' in table (Word97SR2)

    Yep. I looked at your file and agree with SHBB. Click on the row, Table, Cell Height & Width, and take the check mark out of 'allow row to break across..'
    Patricia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •