Results 1 to 5 of 5

Thread: Boot.ini

  1. #1
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Boot.ini

    Hey MerC,

    For the Default line, have it point to wherever your XP installation is. For example:

    If your boot loader looks like this:
    <pre>multi(0)disk(0)rdisk(0)partition(1)WINDOWS="M icrosoft Windows XP Professional" /fastdetect</pre>


    Then the default= line would contain the following:
    <pre>default=multi(0)disk(0)rdisk(0)partition(1)WI NDOWS</pre>


    It must also have the attributes Hidden and System.

    Failing manual fixes, you could boot with the CD and tell it to repair the boot sector, which will include the BOOT.INI.
    -Mark

  2. #2
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Boot.ini

    1. Start Windows XP
    2. Go to Start | Control Panel |system and click Advanced tab.
    3. In "Startup and Recovery" box (third from the top) click "Settings" button
    4. From drop-down list, choose default operating system. You can also change the time for startup menu is displaying and other settings. And you can change settings manualy from this point, if you prefer.
    5. Click OK.

  3. #3
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Boot.ini

    Hi Kap
    Thanx for the input, but the ability to edit boot.ini wasn't the problem. I knew how to do that either within XP or in DOS (which I can boot to.)
    No, the problem was that no matter what the boot.ini contained, there was a spurious 'Default' (actual word) appearing at the bottom of the BootMenu list on start-up. Choosing it failed with an error message and caused a re-boot.
    I feel it may have been something to to with the MBR. A 'quick' re-install of XP restored it to normality. No 'Default' appears and the default OS is highlighted in the BootMenu and will load after the count-down.
    Before re-installing, I tried to insert a proper default system by manual editing (which has worked in the past) but in this case all I got was another 'Default' in the list which did the same thing as the first.

    Rgds

  4. #4
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Boot.ini

    {If anyone finds this post somewhere else, please delete it if possible. I lost it the first time}

    A spurious 'Default' has appeared in my boot.ini file. It is at the bottom of the Menu in a multi-boot system. It is not physically present in the boot.ini file, so I can't edit it out. I would like XP to be the Default - it used to be auto-selected. The 'Default' word is now highlighted, and if allowed to time-out, gives an error message 'Windows Root/System32/hal.dll is missing or corrupt. Please install a good copy. I have expanded a fresh version from the XP CD - no effect.
    I have also tried editing the boot.ini from XP (and setting the default) but it won't go away. Any ideas?

    Rgds

  5. #5
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Boot.ini

    Hi Mark
    Thanks for that. This is the content of my boot.ini file :

    [boot loader]
    timeout=8

    [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(4)WINDOWS="Micros oft Windows XP Professional" /fastdetect
    multi(0)disk(0)rdisk(0)partition(2)WINNT="Microsof t Windows 2000 Professional" /fastdetect
    C:="Microsoft Windows 98SE" /fastdetect
    C:CMDCONSBOOTSECT.DAT="Microsoft Windows 2000 Recovery Console" /cmdcons


    No sign of Default, but the option (broken) appears in my BootLoader menu.
    If I add a Default= xxxxxxxline to the above, I get two 'Defaults' (ie just the word) at the bottom of he list, and both give me the same result.
    In the list on startup all my OSs appear, and clicking on their names loads them. It's just this unwanted Default that appears from outta the blue.
    I'll try you last suggestion, though in the past I cannot remember such an option being made available.


    Laters : A quick (?) re-install of XP did the trick. Thanks for the input.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •