Results 1 to 15 of 15

Thread: MDI in Word 97?

  1. #1
    New Lounger
    Join Date
    Jan 2001
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    MDI in Word 97?

    I would swear that when I first installed Word 97 that it was in MDI (Multiple Document Interface) mode. Today it is SDI for some reason. Does anyone know where the control is for this in Word such that I can bring it back to MDI as a default? Thanks.

  2. #2
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    I didn't even know W97 had an SDI option.

    Just to state the bleeding obvious- of course you've checked this- it is W97 and not W2K?
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  3. #3
    New Lounger
    Join Date
    Jan 2001
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Dear Geof,

    Thanks (BTW, I'm writing in PNG) for the reply.

    Yes, the situation is bizarre. I have Office 97 installed on a Win95 machine and also a Win 98 machine. The W98 machine has the standard behavior of every requested .doc file running under one instance of Word 97. The Win95 laptop, suddenly changed behavior, and now I get separate, multiple instances of Word 97 when I launch a .DOC under Explorer. Many have said that this can't be. It is! <grin>[img]/w3timages/icons/laugh.gif[/img]

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: MDI in Word 97?

    I have seen some talk about a macro that would do this for you. Have you loaded ANY third party macros or Templates?

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  5. #5
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    The problem may have to do with associations. Try this. Go to My Computer/View Menu/Folder Options/File Types tab. Scroll down to Microsoft Word Document.
    Click Edit.
    In the Actions box, click Open (should be the default)
    Click Edit again

    In the application used to perform action, it should read:

    "c:Program FilesMicrosoft OfficeOfficeWINWORD.EXE" /n "%1"

    Your path may differ. It may also be that you shouldn't have a "%1" after the /n. I now have Word 2k & it doesn't have the "%1", but I think it does belong in earlier versions.

    Next, Use DDE should be checked.
    Then, under DDE message:
    [FileOpen("%1")]
    Again, Word 2k has
    [REM _DDE_Direct][FileOpen("%1")]

    Under Application:
    WinWord

    Under DDE Application not running:
    should be blank

    Under Topic:
    System

    If your action for Open is different, especially the DDE, then you can open more than one instance of Word, which is not what you want.

    Hope this helps.

  6. #6
    New Lounger
    Join Date
    Jan 2001
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Dear Phil,

    Kudos! You did it! Everything works fine, and I compared with the Win98 machine and sure enough the settings were (more or less) as you had them.

    Mi amamas tru! (I'm very happy- Melanesian Pidgin <grin>)

    Many thanks to Eileen and the WOW gang, for an excellent lounge. Blessings to one and all. Brian C :-)[img]/w3timages/icons/smile.gif[/img]

  7. #7
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Microsoft. Him bagarup tumas.
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  8. #8
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    I think someone may need to ask Eileen to add a suitable flag for this language.....
    [img]/w3timages/icons/wink.gif[/img]

  9. #9
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    That's my very rusty pidgin for "Microsoft. He's always broken". Or something like that.

    I'm not even sure my learned colleague from PNG could back up my pidgin.

    The clue in my posting is to read phonetically. You may pick up the gist.
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  10. #10
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Maybe there's a pigeon icon
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  11. #11
    Star Lounger
    Join Date
    Jan 2001
    Location
    Houston, Texas, USA
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Phil, has anyone ever told you that you are a genius? Your response here helped me to solve one error on one of our machines here... (something to the effect that he was trying to open a document that did not have a *.doc extension) when of course he was...

    Now he is getting the following message when he opens any doc - double clicking on the doc icon (Word97 on NT 4 SP 6 is closed). "Do you want to revert to the saved *.doc?" and nothing else is open.

    Thanks!
    -Ruth

  12. #12
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Hi Ruth:
    Thank you for the compliment [img]/w3timages/icons/blush.gif[/img].

    The "...revert...document" message is usually caused by temp files lying around. The the user search for

    ~*.*,*.tmp

    & delete them.

    Hope this helps.

  13. #13
    Star Lounger
    Join Date
    Jan 2001
    Location
    Houston, Texas, USA
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    I thought of that, however, that doesn't seem to be the case... I will look further and check MS website.

    Thanks again!

  14. #14
    Star Lounger
    Join Date
    Jan 2001
    Location
    Houston, Texas, USA
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Phil:
    It only happens if I doubleclick on the document icon... not if Word is already open.

    -Ruth

    PS there are not any extra tmp files around....

    -Ruth

  15. #15
    Star Lounger
    Join Date
    Jan 2001
    Location
    Houston, Texas, USA
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MDI in Word 97?

    Phil,
    Found the fix at microsoft... thought you would be interested.

    http://support.microsoft.com/support/kb/ar...s/Q200/9/15.ASP
    Had to remove the association and reopen word to register word... it worked!

    -Ruth

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •