Results 1 to 5 of 5
  1. #1
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Addition Problem (W98, Acc97)

    I am trying to create a total of several fields in a report, i.e. =Field1+Field2+ etc. However, if any of the fields contain a blank (or null) it won't produce a total. I could force zeros as a default, but I don't like the zeros to show up in the data entry form. Is there any way around this problem?

  2. #2
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Newbury, Berkshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Addition Problem (W98, Acc97)

    I haven

  3. #3
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Addition Problem (W98, Acc97)

    Thanks Rupert, I'll give it a shot. I can do it in the query.

  4. #4
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Addition Problem (W98, Acc97)

    You can also use the Nz function:
    Nz([Field1],0) + Nz([Field2],0) + ...
    Francois

  5. #5
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Addition Problem (W98, Acc97)

    Thanks Francois, that worked nicely.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •