Results 1 to 8 of 8
  1. #1
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Seattle, Washington, USA
    Posts
    179
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Forms being corrupted (Access 2K, SR-1)

    I've just split a database into FE/BE and encountered a problem that I don't normally see in non-split database...

    I do my programming in Access 2002 SP 1 and rest of my users run Access 2000 SP2. They run the FE from the network using a shortcut icon.

    Whenever I am done modifying a form, what I do is to copy the "Development FE" file to a new file, delete the old FE and then rename the new copy to identical name of the old FE because users are running the FE as a shortcut link on their desktop.

    This is what happens -- When an user clicks on a button, nothing happens (I have code running) and when my user clicks on the button repeatedly, then an error message pops up then after clicking OK, the DB crashes to the desktop. This happens EVERYTIME I do this copy and paste.

    The only workaround I've been successful is to open the existing FE that users use, delete the "changed" forms and then import from the development copy.

    This problem has been like this ever since I was using Access 2000 and still continues through 2002. Any idea why this is happening?

  2. #2
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Forms being corrupted (Access 2K, SR-1)

    I've seen this problem as well, and it doesn't necessarily occur because you are running with both version of Access (2k and 2002) installed. The only solution I've been able to come up with to solve it is to create a brand new version of the database in 2000 (on a PC that doesn't have 2002 installed), and then import all of the objects from the 2002 front-end. For what ever reason that makes the crash to the desktop go away. I presume you are using the 2000 file format, not the new one with 2002.

    In response to your other question about coexistance of 2000/2002, they don't do well at all together. Things seem to work OK for a while, and then you start getting bizzare failures. Something to do with the VB dll as I recall. The situation has been discussed at some length in other threads - try this post 90704. There are also indications that there is/will be a hot patch to solve the problem, but it's kinda ugly when you get hit with it.
    Wendell

  3. #3
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Seattle, Washington, USA
    Posts
    179
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms being corrupted (Access 2K, SR-1)

    That's odd. This problem has happened to me when I had only Access 2000 last year. That's why I dropped the idea of splitting databases because it kept on corrupting my code even tho' everyone were using Access 2000 (At that time).

    I decided to try splitting DB again using 2002 in hopes that this problem had gone away. <img src=/S/hairy.gif border=0 alt=hairy width=15 height=15>

  4. #4
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Forms being corrupted (Access 2K, SR-1)

    We run numerous databases with a split FE/BE using Access 2000 with no problems. I suspect something else is going on. Do you by chance have Name Autocorrect still turned on? If so, I would turn it off. It's been indicted in many a strange problem. But the problem with 2K and 2002 is very real - several folks in the forum have been affected by it.
    Wendell

  5. #5
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Seattle, Washington, USA
    Posts
    179
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms being corrupted (Access 2K, SR-1)

    Yeah, the Autocorrect is still on. But since you mentioned 2000/2002 problem as well, I guess I'll go back to 2000 for compatibiity reason and turn off Autocorrect and see if it works.

    thanks for your help.

  6. #6
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Forms being corrupted (Access 2K, SR-1)

    As I understand it, you may encounter some problems if you uninstall 2002. Apparently it leaves some DLLs hanging around that are the source of problems. Check the MS knowledge base for the hot fix to see if it has been posted yet. I haven't followed it as I have 2002 only on one PC, and 2000 only on another PC. Hope this improves your stability.
    Wendell

  7. #7
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Seattle, Washington, USA
    Posts
    179
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms being corrupted (Access 2K, SR-1)

    Hand it to Microsoft to really, really muck up your computer! <img src=/S/meltdown.gif border=0 alt=meltdown width=15 height=15>

    <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

  8. #8
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Forms being corrupted (Access 2K, SR-1)

    There is a hotpatch for the problem with the vbe6.dll. However, you have to beg and bully Microsoft Technical Support to tell you how to download it. They have not posted anything publicly about it, you have to squeeze the information out of them. However, as far as I know, the hotpatch only solves a particular incompatibility in the VB editor.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •