Page 1 of 2 12 LastLast
Results 1 to 15 of 26
  1. #1
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Why is Normal.dot Saved=False? (Word 2000 SR1)

    <P ID="edit" class=small>Edited by Gary Frieder on 16-Mar-02 01:27.</P>We've been experiencing issues in our Word environment where users are often getting prompted to save Normal.dot when quitting Word - even when they do nothing more than launch Word and quit it right away (of course they must have the option set to prompt to save Normal.dot).

    This issue has been raised here before and focus always goes towards things like global templates or add-ins. We suspected that as well since we have global templates in our Word environment.

    How then to interpret the following experiment:

    I've moved all of our global templates out of the Startup directory, and have also ensured that no other add-ins have shortcuts to the Startup directory.

    This experiment is done with a brand-new, factory-fresh Normal.dot.

    Launch Word, immediately go to the VB Editor, select the "ThisDocument" object for Normal, look at Properties - the Saved property is set to False! This happens whether or not I have Word set to create a new document upon launch - I also have it set to not run any macros nor automacros. If I look in Templates & Add-Ins there is nothing loaded there.

    Why is Normal.dot getting 'dirtied', merely by launching Word?
    Is this standard behavior (does everyone get this) or does it only occur in some situations?

    Ideas, suggestions welcomed.

    Gary

    PS: A search of the MS KB turns up Article Q241763. This lists four causes:

    Cause 1: The Option to Prompt to Save Changes to the Normal Template Is Turned On
    Their recommendation is to turn the prompt off!!! - yes and let's remove the batteries from the smoke detector too while at it.

    Cause 2: The Microsoft Works Suite 2000 Add-in Is Installed
    Not relevant in our case.

    Cause 3: Word Is Infected with a Macro Virus
    Been there, checked that.

    Cause 4: Stamps.com Internet Postage Add-in Is Installed
    Not relevant in our case.

    This article was first published in September 1999 so this issue has been around for a long time.
    That Cause #1 and suggested "fix" is a whopper - makes me think there is more to the issue that is reported in this KB article (but what is it?)

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Why is Normal.dot Saved=False? (Word 2000 SR1)

    Hi Gary:
    Do you have Tools/Options/Spelling & Grammer/check spelling as you type ticked? Do you get the same result (the saved property being false) if you launch Word with it unticked.

    I know that that option (which I rarely use) can make a document dirty, even after you save it, so I'm just throwing this out as an idea. Also, I assume that you checked the "other" startup folder "C:Program FilesMicrosoft OfficeOfficeStartup".

    Cheers,

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Why is Normal.dot Saved=False? (Word 2000 SR1)

    Thanks Phil for the suggestion.

    This becomes very tricky to test, but it does look like having check spelling as you type set to On, and also having Word set to open a new document at startup, will dirty Normal.dot. However, having the spell setting on but not having Word set to open a new document at startup, will not dirty Normal.dot. But if you then open a new document, Normal.dot is dirtied.

    So it looks like opening a document, with check spelling as you type set to On, will dirty Normal.dot. - This might be applicable to the problem we are having a work.

    Thanks,
    Gary

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Spoke too soon..

    Hi again Phil,

    I've now got every option in Spelling and Grammar turned off.
    And am still seeing Normal.dot change to dirty if I do so much as create a new document.

    This is very strange; where to search next?

    Gary

  5. #5
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spoke too soon..

    To rule out, or detect, options that dirty the template, try the followimg:

    1. If you have not already done so, create a virgin template. I always keep two arround, 1 which is the same as the default Normal.dot created by Word and the other is the same, but includes NO AutoText.

    2. Make sure there's nothing in the STartUp directory or add-ins loaded.

    3. Disable all AV software and any AV Office plug-in.

    4. Using one of the two templates created in step 1 as Normal.dot, start Word.

    Let us know.

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Spoke too soon..

    Thanks for the suggestions.
    I've done everything on your list, other than creating a Normal.dot sans autotext.
    Same result as posted previously.

    Another odd wrinkle: my earlier posts were done from work. Now I'm at home with the same software setup. When I first tried it on this PC, I couldn't 'dirty' Normal.dot for love nor money. This Normal.dot was a venerable one that had been around a long time. I've renamed it and let Word create a new one. Restarted Word - and immediately Normal.dot Saved = False!! (this is with Word not creating a new doc on launch).

    So this is as close to out of the box Word as I can get it, and Normal.dot is dirty as soon as I launch Word. I'm dying to know what is causing this....

    Gary

  7. #7
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spoke too soon..

    I would guess that there's a 3rd party add-in hanging around somewhere. Or an Auto* macro or a document event hanging around.

    Try specifying different templates and workgroup directiories and pull everything out of Word's Startup directory.

    When you next start Word, the ONLY template should be the newly created Normal.dot.

    If that eliminates the problem, then, I'd suggest:

    1. Restore the templates directory to what it was before. See if that matters.
    2. Restore the workgroups directory, see if that matters.

    If still in a bind, find out which app are hooked to Word at Word's startup, e.g., Acrobat, NAV, Winfax.

    Hmm, what about the NAV Office plug-in? Have you disabled that plugin? But leave NAV's AutoProtect enabled.

    Except in special cases, I run with my Normal.dot as read-only.

  8. #8
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spoke too soon..

    <hr>Except in special cases, I run with my Normal.dot as read-only.<hr>
    Hi Howard:
    I was curious about this. Do you find that running normal.dot as read-only causes any problems?

  9. #9
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spoke too soon..

    So far, none.

    I expect that someday, a 3rd party add-in/macro will try to write to Normal. Actually, I think PDFMaker does, but do not use PDFMaker, instead I Print to the Acrobat Distiller printer.

    Sometimes I forget that Normal is read-only and I have to export the userform/module I am working on. I rarely do this, but today was one of those daze.

    Making Normal read-only is primarily to catch any poor housekeeping in my own macros.

  10. #10
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Spoke too soon..

    PDFMaker has one big advantage over printing to the Acrobat Distiller printer. It creates hyperlinks for Table of Contents, Cross References etc. It can also automatically generate the Acrobat bookmarks used for document navigation.

    StuartR

  11. #11
    Uranium Lounger
    Join Date
    Mar 2001
    Location
    New Jersey
    Posts
    6,684
    Thanks
    1
    Thanked 11 Times in 11 Posts

    Re: Spoke too soon..

    Gary,
    I don't know if this will help you find out what's causing the problem, but it might help to solve it.

    Make a copy of the original Normal.dot that you've renamed and then delete the new Normal.dot that Word just created and then rename the copy of your original back to Normal.dot and then reboot the system and open Word. If the Normal.dot is still "clean" then you might try importing a copy of that particular version of Normal.dot into your work machine and see if it comes up clean there. Sounds a bit strange I know, but it is a MS product after all and what have you got to lose at this point. When common sense makes no sense, it's time to get creative.

    Could this be one of Woody's infamous "Bugs".

    ~Doc
    <IMG SRC=http://www.wopr.com/w3tuserpics/DocWatson_sig.gif>

  12. #12
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Spoke too soon..

    Doc,

    Thanks for the suggestion. If I were a stand-alone user I would try this, but my firm has 6000+ users so (a) it's not just an issue with my Normal.dot, ([img]/forums/images/smilies/cool.gif[/img] any solution has to be automatically applicable to 6000+ users.

    Deleting Normal.dot and letting Word recreate it is the standard practice in a situation like this, and it's what MS recommends. There really is no alternative (especially when dealing with 6000+ users) to relying on the new Normal.dots that Word recreates automatically.

    As of now, the issue appears to be caused by a default setting in Word 2000, and the question is what is that setting/why does it occur?

    Thanks again,
    Gary

  13. #13
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spoke too soon..

    Hi Gary:
    I'm grasping at straws here, but I wonder if any of the compatibility options affect whether normal.dot is getting dirty. If you had a machine in which this was not ocurring, you might compare compatibility options. Just a thought.

  14. #14
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Spoke too soon..

    Howard,

    Thanks for your efforts. I should clarify the 'ground-rules' of the situation in which the problem occurs:

    There are no global templates, no COM-adds, and no third-party software of any kind hooking into Word. I don't use NAV, my anti-virus software doesn't hook into Word, and in any case I also did this test with 'live file checking' turned off.
    I develop Word templates for a 6000+ user firm so believe me I know how to check all of the above!<g>

    Analysis of what's going on has to start from the basis that there is nothing but pure, out-of-the-box Word 2000 SR-1 running, with a brand-new fresh Normal.dot that Word just created automatically.

    In this pristine condition, Word sets Normal.dot Saved=False, merely by the act of launching Word (btw even with no new document created at launch). All of the options that Phil suggesting disabling re Spelling/Grammar, have been disabled.

    All of the previous discussions on this topic always focus on globals, third-party add-ins, virii etc. I think in the end most people 'solve' this problem by giving up and setting "Prompt to save Normal" to Off (which even MS gives as a 'solution') - this just doesn't seem like a good solution.

    What I'm getting at here is that this appears to be a pure Word problem - from that starting point, where do we go to track down the cause?

    Gary

  15. #15
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Spoke too soon..

    Thanks Phil,

    The compatibility settings are set to pure Word 2000, so this doesn't seem to be a factor.
    See also my response to Howard. Now that I've got my Word environment in this pristine test state, I'll get back to playing with this problem when I get some time later tonight.

    Gary

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •