Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    Feb 2002
    Thanked 0 Times in 0 Posts

    Excel (Office XP) (Pro)

    I have recently upgraded from office 97 to XP. I have a macro that imports data from a csv file and ever since the upgrade the date field from the csv file appears left aligned(text) and in US date format after the importation. I have checked the regional date settings and they are dd/mm/yyyy and when viewing the csv file in notepad the dates are correct eg 26/03/2002. If I use a copy of excel 97 to import the same csv file there is no problem. Is there some setting I have forgotten about or how can I get round this. Thanks for any reply or direction you can send me in.

  2. #2
    Platinum Lounger
    Join Date
    Feb 2001
    Weert, Limburg, Netherlands
    Thanked 0 Times in 0 Posts

    Re: Excel (Office XP) (Pro)

    Excel XP has a set of new properties with which you can set Excel's regional settings to something else than control panel's I guess that set should be used by you to change the behaviour of excel's CSV import.

    Have a look at tools, options, international and see if anything is there that might help. Note that these settings are also available through VBA, so you can set them on the fly (and back <g>).
    Jan Karel Pieterse
    Microsoft Excel MVP, WMVP
    Professional Office Developers Association

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts