When I went to install the MSDN Subscriptions Library, the install routine stated that my computer did not have the proper version of IE. The choices were to install IE6 or Cancel.

I've been reading all of the warnings about IE6, and since my machine is working fine, I didn't know whether it's worth the aggravation, or whether I should just access MSDN via the internet.

My current version of IE is 5.00.3315.1000 (SP2).
I have W2K with Service Pack 2 installed.