Results 1 to 2 of 2
  1. #1
    Star Lounger
    Join Date
    Sep 2001
    Location
    Anchorage, Alaska, USA
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Services don't run when scheduled

    Tried searching for this here, the KB on microsoft, and a few other places (e.g., Symantec) to no avail so here goes my question ...

    I recently upgraded to a new computer that has Windows 2000 ---- had been using Windows NT. With the new machine, services that used to work fine for running unattended scheduled activities (usually at night) no longer seem to work. For instance I had used Novell's Scheduler to run all sorts of activities under NT that will work just fine now ... but only if I don't Lock my Workstation (Control-Alt-Delete ... Lock Workstation).

    I "solved" that problem by using the the Task Scheduler that came with Windows 2000 instead ...

    but now my problem is with Norton's Speed Disk (and yes I have upgraded to the 2002 Norton Utilities, supposedly compatible with Windows 2000) ... with the previous version of speed disk I scheduled a disk defragmenting to occur nightly ... and it ran without a hitch --- as a service under Windows NT (sdsrv.exe).

    ... with the 2002 version of Speedisk ... I've set it to run every night again ... and the associated service IS running (nopdb.exe) ... but it won't actually launch and run the defragmenting activity --- EVEN if I have the Workstation "un-locked".

    Since this seems to be a problem with more than one non-MS product (Novell Windows 2000 network client version 4.81) and with Norton Speedisk --- I figure it's either a "bug" with my system and/or I have some problem with security settings, etc --- By the way I AM logged in on an account that is a member of the Administrators group.

    Any ideas????!!!!???

    Thanks.

  2. #2
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Services don't run when scheduled

    If you installed Windows 2000 "on the top" of Windows NT installation, settings transition usually doesn't go smoothly. It is better to check and reset ALL settings and services running on your computer. Also re-install Norton utilities.
    BTW, Novell Client v.4.83 is available.
    To improve Novell connections, it is recommended (known Win2k bug) to change value of the Registry key
    HKLMSystemCurrentControlSetServicesNetwareWorkstat ionNetworkProviderDeviceName
    from "DeviceNetwareWorkstation" to "DeviceNetwareRedirector" (without quotes). (WinNT used recommended Redirector setting, Win2k changing it to Workstation setting, that slows down browsing speed.)
    Also disable Remote Computer Task Scheduler (Q245800) by deleting the following key:
    HKLMSOFTWAREMicrosoftWindowsCurrentVersionExplorer RemoteComputerNameSpace{D6277990-4C6A-11CF-8D87-00AA0060F5BF}

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •