Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't SendObject (Access97 SR-1/Outlook 2000)

    I am trying to email a report based on the click of a button on a form. I've done this several times using SendObject in an Access 2000 database with Outlook 2000, but each time I try from an Access 97 database (not converted, and open in Access 97), I get the following error:

    Labels97 can't open the mail session Check your mail application to make sure it is working properly

    Here is the code I'm using:

    Private Sub butCloseForm_Click()
    On Error GoTo Err_butCloseForm_Click

    If CheckSendEmail Then ' Send Email Notification of New Label to Shawn
    DoCmd.OpenReport "rptFindUncreatedLabels", acViewPreview
    DoCmd.SendObject acSendReport, "rptFindUncreatedLabels", acFormatRTF, _
    "Shawn_Berkstresser@satec.com", , , "New Label Created"
    DoCmd.Close acReport, "rptFindUncreatedLabels"
    Else
    ' Do nothing if not checked
    End If
    DoCmd.Close

    Anyone know of any references that might have to be defined to do this?

  2. #2
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Newbury, Berkshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't SendObject (Access97 SR-1/Outlook 2000)


  3. #3
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't SendObject (Access97 SR-1/Outlook 2000)

    Are you saying that it works with Access 2000 on the same machine? Access 97 should be able to use SendObject with Outlook 2000, it certainly works on my machines. There is a MSKB article, Q283173, that addresses this problem and provides a registry fix for it, assuming that you actually did install Access 97 *after* you installed Office 2000.
    Charlotte

  4. #4
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't SendObject (Access97 SR-1/Outlook 2000)

    Thank you Rupert, this offers a good explanation of Automation, which after reading up on the problems/limitations with SendObject, will probably be my method of choice in the future.

  5. #5
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't SendObject (Access97 SR-1/Outlook 2000)

    Charlotte, you amaze me. As always, you know exactly where the answer lies and what the problem is even if it isn't explained. I did load Access 97 after Office 2000, and deleting the registry key fixed it immediately. Thanks again.

  6. #6
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't SendObject (Access97 SR-1/Outlook 2000)

    It's no special knowledge. I just looked up the error message and found exactly one MSKB article that applied. <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •