Results 1 to 4 of 4
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    314
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Eval function can't live with Sandbox 3 ? (Office 2000 Sr1a)

    Having set up an IIS based ASP website I have been advised, amongst other things the following: <font color=red>

    This machine is running the Microsoft Jet 4.0 Engine in "SandBox" mode level 2. It is recommended that you upgrade this to level 3 by modifying the "SandboxMode" value found in the Registry Key HKEY_LOCAL_MACHINESoftwareMicrosoftJet4.0Engines.</font color=red>

    But when I did this then any VBA routines that used the Eval function stopped working. On reverting to Sandbox 2 it all works again but leaves
    a security hole in IIS. <font color=448800>
    I can't believe I am writing this gobbledegook but it is all true! </font color=448800>
    Can anyone suggest why the Eval function should no longer work when the extra security of Sandbox 3 is set in the registry?

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Eval function can't live with Sandbox 3 ? (Office 2000 Sr1a)

    Eval works on my machine with SandboxMode set to 3, but I'm not running IIS. <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>
    Charlotte

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    314
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Eval function can't live with Sandbox 3 ? (Office 2000 Sr1a)

    How important is Sandbox 3 for security do you think?

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Eval function can't live with Sandbox 3 ? (Office 2000 Sr1a)

    I haven't a clue. Even though Eval works on my machine with SandboxMode set to 3, everything else in Access breaks (like switchboard code), so I don't use it.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •