Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    May 2002
    Posts
    20
    Thanks
    0
    Thanked 1 Time in 1 Post

    Cannot insert OLE object (Access 2000/9.0.2720)

    Until recently, I have had no trouble inserting an OLE object into my Access database. (I am trying to insert a jpeg photo by reference; this database contains other OLE jpeg photos.) Suddenly, I am now unable to insert an OLE jpeg. I receive this message: "A problem occurred while Microsoft Access was communicating with the OLE server or Active X control. Close the OLE server and restart it outside of Microsoft Access. Then try the original operation again in Microsoft Access."

    I have searched your knowledge databases to little avail.

    Sometimes I receive this error: "The OLE object isn't registered. The object may be calling an application that isn't installed.To register the application, reinstall it."

    I have reinstalled Access (I did not reinstall the entire MSOffice, however). The .jpg extension is associated with PaintShop Pro. I have uninstalled and reinstalled PaintShop to ensure that the extension is associated.

    As a possible remedy, I selected Tools-->Active X controls-->Image. This clearly was not the answer, but I thought that since other .jpgs in the column were identified as "PaintShop Pro 7 Image" that it might be worth a shot.

    I am taking the following steps when inserting an OLE object:
    1. In Design view of my database Table, I created a field "Photo" and set the data type as OLE Object.
    2.In View mode, I place my cursor in the desired field and select Insert-->Object.
    3. In the Insert Object window, I select Creat from File, click Browse, and navigate to the .jpg file.
    4. I click OK twice. (I have tried selecting Link and Display as Icon in various combinations with no change in the outcome.)]
    5. I receive the error messages quoted above.

    Can you shed some light on what might be happening here?

    Thanks,

    Carol

  2. #2
    New Lounger
    Join Date
    Jun 2001
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot insert OLE object (Access 2000/9.0.2720)

    I was having the same type of problem in A97 db. It worked well w/Win98 but then on a new machine w/WinXP is when the problem arose. I could not figure the cause so I changed the control from OLE to an Image and embedded the jpeg file and everything works well now.

  3. #3
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Cannot insert OLE object (Access 2000/9.0.2720)

    The message doesn't necessarily have anything to do with ActiveX controls. You're trying to insert an OLE object and it's choking on the application that is acting as the server for that object (i.e., if you insert a Word doc into an OLE field, Word is the OLE server).

    I'm not sure why you're using an OLE object for a graphic in the first place. You buy yourself trouble when you store graphics in Access. The fiiles get very large, performance suffers, and you've discovered another problem for yourself. The usual way to do this is to store the location of the graphic in a text field in a table and then use an image control on a form or report to display the graphic.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •