Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    Dec 2004
    Location
    Ontario, Canada
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Access 2000 - Write conflict problem

    I'm getting consistent write conflict errors from my users when they are in my database. I do not understand why this would happen. The records are not locked. There is no reason for anyone to be changing anyone else's records. Regardless of those - the problem is no matter what button the user clicks in the write conflict error box, the record will show #deleted# and cannot be edited in any manner. The only remedy I have found is to copy the record and paste it to make a new record, then delete the old record. I can then delete the #delete# areas and the user can finally re-enter what he was doing when the error message occurred.
    Is there someone who can explain what I might have done in my database to cause this to happen and - most importantly - how to get this to stop!! This database is being used at a critical time right now and the updates are critical. It is too difficult for these people to stop and have to wait for me to fix the problem before they can resume using this database.

    I hope I've been clear enough in my explanation. If not, I would be happy to provide more information.
    Any help with this would really be appreciated...

  2. #2
    Lounger
    Join Date
    Nov 2001
    Location
    Buckinghamshire, UK
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2000 - Write conflict problem

    This is a very serious problem and can corrupt your underlying tables as you may well find that you can get to a point where you will be unable to delete the row containing #deleted# as your problem is that you require record level locking or you have a corrupt LDB file.

    In A2k, go to Tools...Options...Advanced tab. Click on radion buttion NO LOCKS and then Tick OPEN DATABASES USING RECORD LEVEL LOCKING

    Secondly, get all the users off your database and make sure noon is using it. Then go to where the database is located. Look for a small 1..2kb file that has the extension *.ldb If it exists, delete it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •