Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    May 2002
    Location
    Atlanta, Georgia, USA
    Posts
    124
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Numbering problem 2000 to XP (2000/XP)

    I set up my own VBA solution to the restart numbering problem back in 1999, and now I have someone using my template in XP. She loses formatting on numbered lists whenever she opens a document (loses the indent/tab settings).

    I've found lots of references to fixing the problem here, but they seem to be focused on 2000 (where mine works okay). Did MS change numbering in XP, and if so, where can I read up on the changes?

    Thanks!
    Bob
    Writing Consultant / Word Template Designer
    Words Connect

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Numbering problem 2000 to XP (2000/XP)

    It sounds as though the Normal template or her document template is scanning the document and "correcting" the numbered list styles in the document. There have been a number of posts in this forum about settings that affect whether and when styles stored in a document will be updated by a template, but I haven't explored the issue myself and don't recall the answer. If you don't find it after a few minutes of searching, hopefully someone will pick up on this suggestion and post a pointer or a brief explanation.

  3. #3
    2 Star Lounger
    Join Date
    May 2002
    Location
    Atlanta, Georgia, USA
    Posts
    124
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Numbering problem 2000 to XP (2000/XP)

    I did some digging after I posted this, and actually, you were right on. Back when I set the template up (for 97 and 2000), I was having the problem that my numbered list styles were losing their formatting when documents were reopened. My fix was to add code to my AutoOpen macro that copied the numbered list style from the template to the document every time. That "fixes" the problem in 97 and 2K.

    Apparently, when these documents are opened in XP, though, that little piece of code CAUSES the problem it used to fix. If I comment out that AutoOpen code in XP, the numbered list style behaves.

    I'm not sure if this is because a difference in the style definition from 2K to XP or if it is a problem with numbering between the releases.

    Thanks for your help. Any further ideas would be appreciated <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

    Bob
    Writing Consultant / Word Template Designer
    Words Connect

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •