Results 1 to 8 of 8
  1. #1
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    code doesn't work (Win XP/Access 2000 SR-1a)

    Does anyone know of any issues with running VBA code written for Access 2000 on a Windows 98 machine, now being used on a Windows XP Pro machine? I have a database that has been (and still does) work fine on Win 95/98 machines, but on my new Win XP system, some of the code causes Access to close/crash/lockup if I try to run, edit, or compile it. The simple wizard generated code (open form buttons, close form buttons) seems to work fine, but the longer more complicated written code doesn't.

    I don't get any error messages or missing file pop ups, just the standard XP window, Access has a problem and must be shutdown.

  2. #2
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    It has gotten worse, beyond the code, I can't seem to print any reports, especially any that are called from code based on user input. Then when I try to view the report in design or preview mode, I get an error that the report name referred to does not exist. Then I checked all of my macros, the names are their, but they are all completely empty, no lines at all. Now I'm really pulling my hair out...and I have very little left...any ideas???? A copy of the same front end still runs fine on the Win 98 machine, Compact and repair had no effect.

  3. #3
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    This sounds something like the behavior you get with an errant version of VBE6.dll - do a search on the lounge and also on the MS Knowledge base. I haven't heard of any specific problems with WINXP and Access 2000, and my partner runs that combination from time to time. There are however known problems with the installation of some OfficeXP/2002 apps causing similar behavior.
    Wendell

  4. #4
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    Thanks Wendell, that pointed me in the right direction. Seems to be working ok for now. How will compiling the code with the new version of VBE6.dll affect users who are still running the Win98/Access 2000 combination?

    It's amazing to me how many things don't work with XP. Seems like everything I've loaded (even if it was made by Microsoft) has required some patch, fix, setting change, or driver upgrade.

  5. #5
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    As long as you have good backups you should be OK - I presume you are downloading the front-end to the workstation. The problems seem to start when you run the same database in two different environments, and then things go downhill rapidly. If I were you I would keep a copy that has been compiled on Win98, and a second one compiled on WinXP.
    Wendell

  6. #6
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    I was afraid you were going to say that. Since I will be the one making the changes to the front end (yes the users have their own copy), can I make the changes on my XP/2000 system then compile it on a 98/2000 system before distributing it? Will the compile work backwards, or does it only work when going up from 98 to XP?

  7. #7
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    Unfotunately (or perhaps fortunately), I don't know. Let me suggest you make two copies of your known good front-end, and then try going each way. Based on what I've seen and heard, I suspect the one done on your XP system will give you trouble on the 98 system, but testing is the only way to know for sure. I and lots of others would be very interested in what you find, so please post the results.
    Wendell

  8. #8
    Lounger
    Join Date
    Sep 2001
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: code doesn't work (Win XP/Access 2000 SR-1a)

    Just thought that I would follow up on the last post to let you all know how I've made out since upgrading to Win XP. After compiled the code on my XP machine, I have used it with no problems on my XP machine, and that is where I make all of the modifications to the database. All of the users (only 3) are on Windows 98 systems, they have not experienced any problems or strange behavior. I have not had to make any modifications to their systems to accomodated the change. I haven't done any thorough testing or tried to break the database, but we have been able to use it daily just as we had before which is the important thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •