Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    May 2002
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    URL: MailTo Protocol Association Resets Itself

    A lot of folks have experienced my initial problem: when you click a mailto: link in Internet Explorer, Outlook does not correctly open a new message for you to complete and send. The solution that has been provided, multiple times in multiple forums, is to use the following string for the URL:MailTo Protocol file-type association: "C:Program FilesMicrosoft OfficeOfficeOutlook.exe" -c IPM.Note /m "%1". The same solution is provided on Slipstick.com.

    And it works like a champ. My problem is that either Outlook 2000 SR-1, Internet Explorer 6, or Windows 98 spontaneously strips off all the switches, resetting that association to C:Program FilesMicrosoft OfficeOfficeOutlook.exe, which doesn't work. (The only updates/security patches I can think of that have not been applied to these programs are Office 2000 SR-2 and the IE 6 patch that disables Outlook's use of Cascading Style Sheets in its panel displays.)

    I have used the Control Panel's Internet Programs applet to add all the switches back onto the command line. I have used the File Types tab on My Computer's View|Folder Options menu to add the switches. I have used regedit to change the value of HKEY_CLASSES_ROOTmailtoshellopencommand to add the switches. In every case, mailto links work correctly for a session or two or three, and then the command line gets reset to the no-switches version.

    Any thoughts on why this is happening and how to make the fix permanent?

    Bill Betts
    wmwbetts@earthlink.net

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: URL: MailTo Protocol Association Resets Itself

    Ouch. I have Win98SE, IE6, and OL98 -- and fortunately I do not have this problem. I have no answer for you -- however, you MIGHT be able to catch something that is writing to your registry by using a program called "RegistryProt" from wilders.org. If you can find out what is modifying your registry, perhaps you can then figure out how to stop it.

    The program is available here.

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: URL: MailTo Protocol Association Resets Itself

    The "Protocol Association Resets Itself " can NOT reset it's self. You have something or run something that resets it. It has been known for other ISP software that will reset it. A lot of ISP's do NOT support Outlook just OE, so by default their software will set the default.
    Who is your ISP?

    Are you running ANY software that they (ISP) provided you?

    Are you running any AV software that is checking your out going email?

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  4. #4
    New Lounger
    Join Date
    May 2002
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: URL: MailTo Protocol Association Resets Itself

    Earthlink is my ISP and it DOES support Outlook 2000. And I have confirmed that my copy of Outlook is configured in accordance with Earthlink's current set of instructions. Also, just to be crystal clear, when the mailto association is changed without my knowledge, it is NOT being changed to OE. The default mail program is still Outlook 2000, but the necessary switches are no longer part of the command line.

    The Earthlink software (version 5.1) is installed on my PC, because that was the quickest way to establish the connection when I made Earthlink my ISP. But it is not being used. Earthlink's software includes a setting that makes Internet Explorer the default program for accessing the service, and I have activated that setting. Also, I turned off Earthlink's "automatically check for updates" feature for the Earthlink software. So, as far as I know, the only thing that Earthlink's software does is occupy space on my hard drive.

    I use Norton AntiVirus and have just turned off the "check outgoing email" feature. I should know soon enough whether that makes a difference.

    For the record, you are right about the phrase "protocol association reset itself" in the subject line for my original post, but it was the most explicit wording I could come up with that did not exceed the character limit for subject lines.

    Bill Betts
    wmwbetts@earthlink.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •