Results 1 to 10 of 10
  1. #1
    Star Lounger
    Join Date
    Jan 2001
    Location
    Switzerland
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Opening CSV files (2000)

    Folks,

    I am having a weird problem with CSV files.

    Here is the scenario: XL2k - Win2k - international list separator semi colon (;)

    Now create a CSV from Excel - close - open - everything works fine.

    Next step: close Excel and double-clik the CSV file from the windows explorer. Excel launches but does not "interpret" the file (i.e. the cells are not loaded, everything ends up in the first column). Close the file and use "file -> open" - everything works...

    Clearly when opened from the Explorer the international list separator is not used (if your replace the semi-colon by a single colon it works fine in the "double click" scenario but fails the "file -> open" approach).

    Is this some sort of bug or I am missing something obvious ?!

    Any info welcome

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Opening CSV files (2000)

    <img src=/S/hmmn.gif border=0 alt=hmmn width=15 height=15>, I don't get this result in XL 2k on W2k on files saved as any kind of CSV; opening from Explorer fires up Excel and the data loads into the appropriate columns.
    -John ... I float in liquid gardens
    UTC -7ąDS

  3. #3
    Star Lounger
    Join Date
    Jan 2001
    Location
    Switzerland
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening CSV files (2000)

    Do you have the list separator set as ";" ?

    --alex

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Opening CSV files (2000)

    Pardon me, I did not, but now that I created one, I can't get a ';' delimited file to load correctly formatted whether from either Explorer or from Excel File Open.
    -John ... I float in liquid gardens
    UTC -7ąDS

  5. #5
    Star Lounger
    Join Date
    Jan 2001
    Location
    Switzerland
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening CSV files (2000)

    That's strange. I have tried on numerous systems with the same result. Let me see...

    --alex

    PS: Is the CSV you create indeed delimited with semi-columns ?

  6. #6
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Reading/Swindon, Berkshire, United Kingdom
    Posts
    664
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening CSV files (2000)

    Just butting in here, but I couldn't reproduce the behaviour either. You are talking list seperator from control panel/regional settings?

  7. #7
    Star Lounger
    Join Date
    Jan 2001
    Location
    Switzerland
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening CSV files (2000)

    <hr>Just butting in here, but I couldn't reproduce the behaviour either. You are talking list seperator from control panel/regional settings?

    <hr>
    Indeed. Have to check the specifics of the offending machines. Will be back

  8. #8
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Opening CSV files (2000)

    After initially not doing it right <img src=/S/sorry.gif border=0 alt=sorry width=15 height=15>, I took the CSV I had created with commas, loaded it to Notepad, replaced every "," with ";" and then tested it. When I loaded it into XL I did not save any changes after I closed it each time.
    -John ... I float in liquid gardens
    UTC -7ąDS

  9. #9
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening CSV files (2000)

    On my machine (regional settings Dutch - comma as decimal separator, semi-colon as list separator) I get exactly the same behavior as you describe:

    - File created in Excel and saved as .csv has semi-colons as field separator.
    - File opens correctly from within Excel.
    - File is messed up when double clicked from Explorer.
    - Reverse is true if commas replaced by points and semi-colons replaced by commas.

    I'm afraid this is not to be helped. It is one of the areas where Microsoft failed to implement localization completely. They went half the way, but deep down they still expect everybody to use US settings. If you really need to work with .csv files a lot, it's best to change Regional Settings to US temporarily. If you keep the Control Panel open, you can switch back and forth easily (although it's still a <img src=/w3timages/censored.gif alt=censored border=0> nuisance).

  10. #10
    Star Lounger
    Join Date
    Jan 2001
    Location
    Switzerland
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening CSV files (2000)

    Hi !

    Thanks for your reply. I did some further testing and the problem is 100% reproducible on our machine with French regional setting and French version of XL.

    Anyone else with non English XL ?

    --alex

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •