Results 1 to 3 of 3
  1. #1
    Bronze Lounger
    Join Date
    Jan 2001
    Location
    Virginia, USA
    Posts
    1,560
    Thanks
    37
    Thanked 1 Time in 1 Post

    Sorting disconnect (2000/9.0.3821 SR1)

    I've built a report that displays the courses we offer, grouped by what we call "criterion number." Within each criterion group, I want to sort the courses alphabetically by course title. The datasource is a query, where I've specified that I want to sort first on the criterion number (1-10, ascending order), then by course title. In datasheet view, the query does exactly what I want--no problem there. However, the report displays the courses in what appears to be a totally random order within each criterion group. I can't detect a pattern. The criteria numbers sort just fine, and the right courses appear within each criterion. But the courses--which should appear in alphabetical order--seem to appear in random order. Each course has a course ID number, which also appears on the report, but they're not in numerical order either. The query has it right--why can't I get the courses in the correct order?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Sorting disconnect (2000/9.0.3821 SR1)

    This is confusing indeed the first time you run into it <img src=/S/brickwall.gif border=0 alt=brickwall width=25 height=15>.

    You have to do *all* sorting in a report in the Sorting and Grouping window. Unless you use the query for other purposes too, you might as well remove the sort order from the query, because the report ignores it.

    In the Sorting and Grouping window, select the criterion number field in the first row (if you haven't done so already), and the course title field in the second row. this will make the report sort on criterion number first, and on course title within each criterion number.

  3. #3
    Bronze Lounger
    Join Date
    Jan 2001
    Location
    Virginia, USA
    Posts
    1,560
    Thanks
    37
    Thanked 1 Time in 1 Post

    Re: Sorting disconnect (2000/9.0.3821 SR1)

    Yes, Hans, I see what you mean! I followed your advice, and the problem is fixed! (Like you said, I just assumed the report would follow the sorting order in the query! <img src=/S/doh.gif border=0 alt=doh width=15 height=15>

    Vielen dank!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •