Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Jan 2002
    Location
    Bismarck, North Dakota, USA
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Run time error (Word 2002)

    I broke it but don't know what I did....please help!

    I have a global template called WLF that I have loaded as an AddIn. It contains the bulk of my macros and forms. They had been working just fine but then I must have changed something I should not have but I can not figure out what. <img src=/S/stupidme.gif border=0 alt=stupidme width=30 height=30> I have several macros that just basically call a form. At first the form would display but then, if the form called for an AutoText entry to be inserted, I would get the error message 'Complie error in hidden module'.

    I did a search and found a post that suggested looking at the Tools->References section. I made some changes there so that they are now the same as an old version of my WLF template where these macros, etc still work. But now the macro will not even display the form and I get an error message that says 'Run time error 424, object required'. The statement that is highlighted is 'Normal.frmAddress.Show'.

    I realize the obvious solution would be to reload the old version of WLF that still worked but unfortunately I made a lot of revisions to WLF before I realized I had screwed it up and don' t want to lose all of the good changes too.

    Any suggestions would be most welcome, I am about ready to give up on all of it!

    Thanks,
    Missy <img src=/S/hairout.gif border=0 alt=hairout width=31 height=23>

  2. #2
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Run time error (Word 2002)

    The reference list shows no "Missing" entries???
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Run time error (Word 2002)

    Sounds like a couple of different things so here are a couple more suggestions:

    Open this global template as a document so you can get to its code modules, then in the VB Editor, click on "Debug > Compile [project]" and see if you get taken to any compile errors.

    As far as the runtime error, it sounds like you have code in the global template which is trying to load a userform called "frmAddress", which is located in Normal.dot - are you supposed to have a userform called "frmAddress" located in Normal.dot, and is it missing? A really good rule to live by anyway is to never put stuff like this in Normal.dot; rather if it's a form that gets called from the global template, put the form and its code in the global template too.

    Hope this helps,
    Gary

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •