Results 1 to 4 of 4
  1. #1
    Star Lounger
    Join Date
    Mar 2002
    Location
    Ventura, California, USA
    Posts
    56
    Thanks
    0
    Thanked 0 Times in 0 Posts

    From not showing updates (2002)

    I have 3 tables in database. All set with one to many relationships. I then put a subform of a child table into my main form. When I update the sub form it takes the new data and stores in the proper table, but the subform always shows blank as if the table is empty. But when I open the table the data is there. Its as if it will take the data entry and put in the table but then it will not show it.

    This is irritating me because I know it is something I am just over looking.

    Any Help??

    Also, this form is shown as a datasheet as it is a one to many relationship.
    Dan

  2. #2
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: From not showing updates (2002)

    This looks like the Link Child Fields and/or Link Master Fields property of the subform is missing.
    Francois

  3. #3
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: From not showing updates (2002)

    Does the data coming from the subform have the correct value in the field that relates it to the main table?
    If so, did you have to enter this value yourselve or did it get there automatically?

    If the subform is correctly linked to the main form, you don't need to enter any data into the linking field of the child form.

    If you change the subform from datasheet view to continuous forms view, you can then control the format of the form, including hiding the linking field if you want.
    Regards
    John



  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: From not showing updates (2002)

    Does your subform have its DataEntry property set to true? If so, it will allow you to enter data but won't display it.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •