Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Dec 2000
    Location
    Ellicott City, Maryland, USA
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts

    switchboard manager

    Seems the switchboard manager (SM) in my Access 2000 has stopped working. By that I mean, I can select SM, add new switchboards, edit them, add, remove whatever, but none of this is shown when I actually try using the SM. When I select the SM, there is only one line that reads "There are no items for this switchboard page". The form looks OK and the table looks OK.

    I have uninstalled Access 2000 and reinstalled it twice with the same results. I've also noticed that in existing "old" databases the existing SM works OK, But, if I delete it and attempt to create a new one, same failure.

    Last I tried dragging a "working" SM to my database, but that just fails all over the place. Anyone else having problems with switchboard manager?

    Mike Hayes
    p.s. My Access97 switchboard manager still works as expected.

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: switchboard manager

    First of all, what do you mean when you say it doesn't work? If you can select it and create pages, etc., then something is working. Do you have a form called Switchboard that claims not to have any pages? Is that the name of the switchboard you actually created? Is that what fails (rather than switchboard manager)?

    Does the Switchboard Items table exist locally and can you see the correct records when you open it? If you delete the switchboard items table and your switchboard form, can you create a new one using Switchboard Manager? If you do, does that one fail as well? Does the code inserted into the Switchboard form compile properly?
    Charlotte

  3. #3
    Lounger
    Join Date
    Dec 2000
    Location
    Ellicott City, Maryland, USA
    Posts
    30
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: switchboard manager

    "First of all, what do you mean when you say it doesn't work? "
    I think I already answered this in my original post where I stated "When I select the SM, there is only one line that reads "There are no items for this switchboard page"." At one point I had 5 forms added on the main SB, but none would show!

    I also stated "The form looks OK and the table looks OK." but, I didn't know what a good form should look like!

    I think I finally figured out what was happening, but I can't explain it. I took my database to work and copied it onto that PC. I deleted the SB form and table and created a new one. It worked as expected there! Upon investigation, I find that the switchboard table was the problem. A good working SB table has SB ID, Item # and commands, in every line. For that period where my SB manager was acting up, the tables had blanks in some of those fields. (I still got some of my test DB created while troubleshooting, and have verified I'm really not crazy :-)

    Last thing I did here was to completely remove the entire Office 2000 Pro suite and reinstall it. So, I'll have to assume a corrupted file or Win registry was the problem.

    Thanks for jumping in to help.

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: switchboard manager

    It was your terminology that was confusing. The switchboard manager is a database utility. The switchboard itself is a table-driven form. I couldn't tell which one wasn't working.

    Tables (and therefore switchboards) do sometimes go haywire, and gaps or missing data in records in the Switchboard Items table will cause exactly the behavior you described, as can damaged code behind the switchboard form. It doesn't take a corrupted Office installation to cause this, so you may encounter it again some time. I have rarely experienced it in the past with earlier versions of Access, but never with 2000.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •