Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    Manassas, Virginia, USA
    Posts
    363
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Use SendObject code with GroupWise (Access xp, SR1)

    I have searched for previous posts relating to using GroupWise to send an email message and was unable to find anything I could figure out how to make work. I am trying to use the following code to send a confirmation to someone after they have registered for classes. The code partially works in that it does create the rich text format file and includes it as a GroupWise attachment. The subject appears in the proper place but I can't get the TO: which is a memory variable containing the contents of a field on my form or the Message Text to appear. What happens is the GroupWise email message I am sending appears on my screen as if I had answered "True" to Edit Message and the TO: and Message section are blank. If I fill in that info, I can click send and the message gets sent. However if something I can do will make it work like it should, that would be great.

    DoCmd.SendObject _
    ObjectType:=acSendReport, _
    ObjectName:="emailLetter", _
    OutputFormat:=acFormatRTF, _
    To:=emailto, _
    Subject:="Registration Confirmation", _
    MessageText:="Please open the attached file.", _
    EditMessage:=False
    Judy Jones, Computer Training Specialist
    Manassas, Virginia

  2. #2
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Maidstone, Kent, England
    Posts
    398
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Use SendObject code with GroupWise (Access xp, SR1)

    I tried your code in a module on my machine, A97 and W2k and it worked O.K.

    All can suggest is that you double check the emailto variable is giving a valid email address.

    HTH

    Peter

  3. #3
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Use SendObject code with GroupWise (Access xp, SR1)

    I don't have xp so here's a quess, maybe xp needs all the fields defined (even though some are not applicable, eg the BCC field).
    What I am saying is to let Access prompt you for each field as you enter the SendObject command, and don't put in the field identifiers (eg To: or Message
    HTH
    Pat

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Use SendObject code with GroupWise (Access xp, SR1)

    There have been several threads in VB/VBA on using Groupwise, but that was with VB and didn't use SendObject. If you're interested, take a look at this thread. There have also been a few threads in this forum. Take a look at this one for example. Again, not using SendObject.
    Charlotte

  5. #5
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    Manassas, Virginia, USA
    Posts
    363
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Use SendObject code with GroupWise (Access xp, SR1)

    Just in case anyone else has this same problem let me explain what I found was keeping the code from working correctly. When Office xp was installed Outlook was also installed even though it was not needed since we are using GroupWise. It was later removed. Apparently it left something behind because I had someone remove it, install Office 2000 which did not contain Outlook, everything worked OK. Then they installed Office xp and this time the install process did not attempt to install Outlook and the code worked fine.
    Judy Jones, Computer Training Specialist
    Manassas, Virginia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •