Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Open in new window (6.0.2800.1106)

    I just "upgraded" 6.0 with MS Service Pack 1 and found I could no longer automatically open toolbar links in a new window. I can't recall what I did the last time to make this work, but I think there was a switch somewhere --possibly in IE6 -- that forced all links and favorites to open in new windows (which was what I wanted). The only time the active window would go to a new URL was when the address was entered and the GO button clicked. I've looked in Internet Options, Tweaki and TweakUI, but can't find anything that looks like it would restore the function I used to have. I know about "Shift-click" and "Right-click/Open in New Window," but they're not what I'm referring to, and they don't work on the Links toolbar anyway. At the expense of appearing to be an absent-minded idiot, can anyone tell me what I did before, and how to do it again?

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    You might try this.
    Attached Images Attached Images

  3. #3
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    Thanks for the quick response, but I tried your suggestion and got no change. Clicking on a toolbar link did not create a new window after checking "Internet Options/Advanced/Reuse windows for launching shortcuts". The lack of a capital "W" in windows makes me believe that particular selection is meant to produce the opposite result of what I want: use the same window, not create a new one. Thanks again.

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    What happens if you Shift+click the link? Or right click & then choose Open in New Window. However, I don't know why Rick's (rmrucker) method wouldn't work for you. Sometimes IE options don't take unless there is a complete reboot. Have you treid that?

  5. #5
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    1) I tried closing and reopening IE after checking "Internet Options/Advanced/Reuse windows for launching shortcuts". No change.
    2) There is also no change after "Internet Options/Advanced/Reuse windows for launching shortcuts" is checked and I do a complete reboot.
    3) Shift-Click doesn't seem to have any effect on my Links toolbar selection. When I Shift-Click on a toolbar link, the new URL opens in the active IE window, not a new one. I can't notice any difference between using Shift-Click and not using it. This is true before and after checking "Internet Options/Advanced/Reuse windows for launching shortcuts", even after rebooting as you suggested.
    4) Right-Click doesn't work on a Links toolbar selection because it's not presented as an option on the pop-up menu.
    5) FYI, I do get a new window with a simple click on an email (Outlook Express) link, such as the one in the email generated by your reply to my post, but that happens only if the only IE window open is the original one. If there is more than one IE window open when I click on an email link, it is only the second window opened that switches to the email link URL. Shift-Click doesn't do a thing on an email link, and Right-Click doesn't produce a menu with "Open in new window" as a choice.

  6. #6
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    I should also add that double-clicking on an Internet Shortcut icon on the desktop also doesn't open a new window. Instead, it opens its URL in the first-created IE window, even if there are other IE windows open. I tried Shift-Double click on the icon, too, and that doesn't change anything, and, again, there is no "Open in new window" selection presented by a Right-Click menu.
    Thanks for your advice, but there has got to be something that works because I had it working before where any link I clicked would open in a new window. That did get me a lot of windows at times, but I didn't have to hunt for nested windows with the Back and Forward buttons, and I could simply close the ones I didn't want anymore.

  7. #7
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    Sorry to confuse you and disappear. That box should be unchecked -- like in my image.

    Hmmm... the Links bar is just a sub-folder for Favorites -- and my recollection is that by default, the Favorites URL's always open in the same window.

    This behavior should be controlled in you registry under HKCRInternet Shortcut. But I cannot seem to modify it even if I want to! Maybe I need to reboot or close IE first...

    No, I don't think so. It is my foggy recollection that this behavior changed after one of the IE updates -- I don't recall which one.

    The best I can offer you is a right-click option to "Open in a New Window". I think the behavior you are describing is by design from Microsoft.

    To add the "Open in a New Window" option, run this .reg file:

    REGEDIT4

    [HKEY_CLASSES_ROOTInternetShortcutshellOpen in New Window]

    [HKEY_CLASSES_ROOTInternetShortcutshellOpen in New Windowcommand]
    @="rundll32.exe shdocvw.dll,OpenURL %l"
    Attached Images Attached Images

  8. #8
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    Thanks for the Registry info, I now get "Open In New Window" as a Right-Click menu choice. But -- and it's a big "but" -- the "Open In New Window" menu selection doesn't work. All it gives me is the dialog box "Program Not Found". Where do I go from here?
    Attached Images Attached Images

  9. #9
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    Hmmm.... I cannot really tell what it cannot find! Is it the .url (unlikely), or rundll32.exe?

    I think I got it. Did you cut&paste that .reg file -- or try to retype it yourself?

    The key may be in the last character. It is "percent lower-case L" not "percent one".
    ______

    Well, NO! I just modified to a "one" and the dang thing STILL worked!

    You should actually find the EXACT SAME value under the opencommand value -- so you can just cut and paste it from there if you like.

  10. #10
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    I haven't had much experience adding things to the registry, but I think I followed your instructions properly. Using Edit/New/Key I added "Open in New Window" to the "Internet Shortcut/shell" key, and then added "command" below that. Using Edit/Modify I pasted your line (@="rundll32.exe shdocvw.dll,OpenURL %l") into the Data column, so whatever your last character was is what was entered. However, I also included the quotation marks at the end of your line when I pasted it as I thought they were part of the instruction. I corrected that error and made sure the last character was a lower case "L" by deleting and rewriting it. Nothing changed. After a complete reboot of my machine I still get the "Program Not Found" dialog box asking for the location of the link I right-clicked on.
    This is strange because IE already knows where the link is since it identifies both its location and URL in the Properties Dialog. It also must have the correct information because it delivers the proper URL on a left-click, it just doesn't do so in a new window. Further, when I right-clicked on a link, selected "Open in New Window", and tried pasting the location from the Properties Dialog/General tab, not only could IE still not locate the URL, it began presenting a dialog box showing the IE Properties Dialog's specified location and URL as "not a valid Win32 application." The link still works on a left-click, but not in a new window, only the active one. In essence, IE has now taken away my ability (there's only an "OK" button to press) to even specify a different address for the link I want without recreating it from scratch. Not that that would be difficult, but even if I can figure out what particular address IE is asking for, I'd literally have to duplicate the process for every one of my links, and I have a hell of a lot of them.
    I couldn't combine all the illustrations into one .jpg file of less than 100K so they would display with this response, so I'm attaching them as a Word 2000 doc. I don't know if they will display without opening Word. If that becomes a problem, I'll figure out another way to send them.
    Attached Files Attached Files

  11. #11
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    I did not look at the Word attachment, but your registry editing is incorrect. That explains the problem.
    The "at" symbol just stands for "Default". ;-]

    Delete what you did entirely. Open Notepad. Copy EXACTLY the words between the dotted lines:

    --------------------------------------------------------------------------------------

    REGEDIT4

    [HKEY_CLASSES_ROOTInternetShortcutshellOpen in New Window]

    [HKEY_CLASSES_ROOTInternetShortcutshellOpen in New Windowcommand]
    @="rundll32.exe shdocvw.dll,OpenURL %l"

    --------------------------------------------------------------------------------------

    Paste them on to the New Notepad document. Save this to your Desktop as "OpenNew.reg". Make sure the bottom of Notepad says: "Save as type: All Files (*.*)" before trying to save this as a .reg file.

    Find this file on your Desktop and double-click it. Windows will ask if you want to Merge this into your registry. Say yes. You are done.

  12. #12
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    In the end it should look like this -- except you will note I still have the "one" at the end!

    If you try to do this yourself, don't add the quotes and the @ is just telling regedit that this is the "(Defaut)" entry!!
    Attached Images Attached Images

  13. #13
    Lounger
    Join Date
    May 2002
    Location
    CA, USA, California, USA
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    BRAVO!!!
    And many, many thanks.
    I don't have what I used to have -- God knows how that might be accomplished! -- but the "right-click/Open in New Window" route will certainly give me back most of it.
    I even learned more about the registry in the bargain.
    Woody's Lounge is the greatest!

  14. #14
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    <hr>Sorry to confuse you and disappear. That box should be unchecked -- like in my image.<hr>
    Boy, I totally missed that fifty50 kept saying he checked the box. I read it as unchecked. I wonder if he ever tried unchecking the option.

  15. #15
    New Lounger
    Join Date
    Sep 2002
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open in new window (6.0.2800.1106)

    I had the same problem after upgrading. There is no resolution I have been able to find. Registrry hacks don't work and the behaviour seems related to an old inbuilt control in IE that restricts opening new windows if IE thinks there is not enough physical memory/,gdi , or user resources to do so. But now it behaves this way irrespective of how much memory you may have (half a gig for me) or how much gdi and user resources are free.
    But, you can regain the behaviour however from activating the links toolbar on the desktop taskbar, the only answer I have found.
    Regards,
    Rob <img src=/S/aussie.gif border=0 alt=aussie width=21 height=22>

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •