Results 1 to 6 of 6
  1. #1
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    727
    Thanks
    1
    Thanked 0 Times in 0 Posts

    98 NIC driver problem

    Edited by WyllyWylly to add URL code. See the Quick Guide. <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

    My friend's computer has an onboard NIC. They just got internet cable, but the NIC had never been used, so it was not functioning properly.
    Only sometimes it says that it found new hardware and it says it finds a Davicom 1/10/100 ethernet adapter. The normal windows 98 "new hardware" section lists it, but still requires the driver. I tried downloading one of the drivers from http://www.davicom.com.tw/download/driver.htm, but that didn't work. I don't see the Davicom 1/10/100 listed. Without the NIC running, he has no cable. This is one of those small computers that you can't add anymore cards to it. Everything is on-board.

    Anyone have any clues?

    --KZ

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Brantford, Ontario, Canada
    Posts
    2,391
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 98 NIC driver problem

    My suggestion would be to determine what the motherboard is (Make / model / etc..) and find a set of drivers for it. It's a small chance, but the driver for a Davicom 1/10/100 Enet adapter proper (if there is such a beast), could be differnet from the "on-board" version.
    Christopher Baldrey

  3. #3
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 98 NIC driver problem

    Davicom 1/10/100 does not appear to be the model number, it's likely a product name.
    If you go to t eDavicom home page, you'll find a listing for a USA contact. Might just be a sales office, but I'd suggest calling them.

    You should also be able to get info from the manufacturer of your computer system.

  4. #4
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    727
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: 98 NIC driver problem

    Thanks Howard, I did e-mail them last night. We'll see if they respond. If not I'll call them.
    It is strange that Windows "finds it", but then doesn't have a driver for it.

    --KZ

  5. #5
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 98 NIC driver problem

    Have you tried my all-time favorite Driver website? (http://www.driverguide.com)

    Give that a shot. I did a quick search for Davicom and Network adapter that resulted in dozens of entries. I'm almost certain you'll find one that will match your hardware there.

    Hope this helps

  6. #6
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    727
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: 98 NIC driver problem

    Thank you everyone. What it turned out to be was the BIOS had the NIC disabled. Grrrr.
    I had first downloaded the correct driver, but it continued to not work. Now it works great.
    It's always something unexpected.

    --Ken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •