Results 1 to 8 of 8
  1. #1
    Star Lounger
    Join Date
    Mar 2002
    Location
    Eugene, Oregon, USA
    Posts
    66
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Woody's Field Sniffer Causing Problems (Word 97)

    After installing Woody's Field Sniffer, I can no longer read or use many of my templates. I use documents we have created such as "Observation Reports" where we edit fields such as "Contractor," "Date,", and "Report No." After loading Field Sniffer, all my fields look like {FORMTEXT] or {FORMDROPDOWN}, etc. I can unprotect my documents, then modify the fields, but I've then lost everything I've done before. On my unprotected documents, it looks like I can select the fields and hit Shift-F9 and see the original text. This also happens in Outlook97.

    I've since removed Field Sniffer, but Word and Outlook are still in the "View Field Codes" mode. How do I get out of this mode, not on a per document basis, but throughout my Office software?

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    Generally speaking, using Alt+F9 will toggle the field code display from codes to results and back again at the application level. However, in a protected form, you cannot toggle. You need to close the new document, toggle field codes off, and then use File|New again (or File|Open again if you are working with a saved document).

    As for Outlook, I don't use Word as my editor, but I suspect it would be the same. Does this solve the problem?

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    One other suggestion, if you envision toggling back and forth and want a visual indicator before you open the document, add the View Field Codes command to one of your toolbars. When the codes are toggled viewable, the button will appear to be depressed (as shown in the inset picture). However, there must be at least one document open for this to show (such as the blank document that normally appears when you start Word).
    Attached Images Attached Images

  4. #4
    Star Lounger
    Join Date
    Mar 2002
    Location
    Eugene, Oregon, USA
    Posts
    66
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    I don't want to have to toggle the field code display for each document, protected or not. I uninstalled Field Sniffer, yet all my field codes are still displayed. I don't use Word as my Outlook editor either, yet when I opened my email notification of your reply to my post, hyperlinks look something like this: {HYPERLINK (followed by additional text.)}. Apparently the installation of Field Sniffer changed a default setting in at least two of my Office applications, but uninstalling the program did not put the settings back. Can I change the setting manually once and for all?

  5. #5
    Star Lounger
    Join Date
    Mar 2002
    Location
    Eugene, Oregon, USA
    Posts
    66
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    Another problem I just encountered is that when I select Tools|Customize, nothing hapens. I no longer get the Customize box as shown in your picture.

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    Hmmm... is Customize grayed out? It's not available in protected documents. If it's enabled (not grayed out) but it just doesn't work, your menus could have become corrupted. Can you access the dialog by right-clicking an empty part of the Toolbar area and choosing it from the bottom of the Toolbar list?

    An unlikely scenario is that you have a "do nothing" macro overriding the ToolsCustomize command. See if you can run the native command using the Macros dialog (Alt+F8) by dropping down the Macros in list and choosing Word Commands, highlighting ToolsCustomize, and clicking Run. If that works, you can look around for the do nothing macro or approach it first as a menu problem. You can Reset your menus, but that would be the last resort if you have customized them.

    I realize this is rather quickly and sketchily explained, but I'm on the run...

  7. #7
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Hornsby Heights, New South Wales, Australia
    Posts
    3,822
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    Press Alt-F9 to hide (toggle) the fieldcode, then <!post=take a look here,183056>take a look here<!/post>.
    Cheers, Claude.

  8. #8
    Lounger
    Join Date
    Jul 2002
    Location
    Sun Prairie, WI, USA
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Woody's Field Sniffer Causing Problems (Word 97)

    I don't have a clue about the Field Sniffer, but I was able to use the response in this thread to (seemingly, in the eyes of the client) pull the solution to their problem out of my @#$!%!

    They, too, were seeing only the [FIELDTEXT] and [FIELDDROPDOWN] fields in a protected document that was sent to them. They couldn't edit but I was able to edit it just fine, so I figured it was something with their Word setup. I added the Show/Hide Field Codes button to a toolbar in Word with nothing open, then reopened the document with stunning success. Gold star to you! Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •