Results 1 to 5 of 5
  1. #1
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    968
    Thanks
    19
    Thanked 4 Times in 4 Posts

    Default email account behavior (Outlook 2002 SP2)

    Bug in OL2002 handling of multiple email accounts?

    I have my own domain name which I use solely for email. I don't have a web page and I do this for potential portability of my email account, should I wish to change ISP services. At my current ISP, I have a "parked domain". This means that I pay $30/year for essentially email support only. I get 5mb of email storage and 3 possible email addresses. OTOH, the charge for a full service account with bigger email plus web storage is something like $10 or $20 per month.

    With this ISP, I have aliased my domain name to my primary email address. Anything coming into the ISP addressed to anyname@mydomain.com gets routed through my primary ISP email address (but it will show my domain name and not the my ISP standard address).

    I have defined 2 accounts to Outlook. One is the primary ISP email address and the other is for sending email under my domain name (so that the email gets stamped with my domain address and not the ISP standard address). So the primary account is what I have to use to get all email (receiving ONLY) and the second is for sending only.

    When I switched to OL2002, I started getting errors with this setup where my sends to my 2nd account (my domain address) wouldn't work. OL2002 kept wanting to send all main through the main ISP receiving account. I tried setting the 2nd account (sending) as the default but this didn't solve the problem completely. Some mail would still go out stamped with the my primary receive address and NOT my domain address. I wasn't sure why yet.

    So I went into each account and did some editing on the POP3 settings. On the first account for receiving, I removed the outgoing SMTP server info and zeroed out the port number. On the 2nd account for sending, I removed the incoming POP3 server info and zeroed out the incoming port number. I also checked on the box for my outgoing server requires authentication and to "logon to the incoming mail server before sending email". Btw: Outlook doesn't like having blank entries for POP3/SMTP fields, so I used the word "dummy" where I removed server addresses. Now it is impossible to send from the receiving account or receive from the sending account.

    Now everything works (mostly). I've found that even though the 2nd account is set as the default, which should mean that it would be used as the primary account for sending email, OL2002 will still try to send from the 1st account (receive only account) IF I am REPLYING to an email. Apparently, OL2002 ignores (overlooks) the DEFAULT setting in replies and chooses to use the incoming account! This means that in replies, I have to click on the Accounts drop down and choose the sending account or the mail will sit in the Outbox forever generating errors (because I have no SMPT address in that account). Having to remember to click the drop down on replies is an annoying extra step that I really shouldn't have to do (and wouldn't have to do if MS was clear on the understanding of the word default). Hopefully, MS will fix this in Outlook 11 or offer a checkbox to override the default default behavior.

  2. #2
    New Lounger
    Join Date
    Feb 2003
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Default email account behavior (Outlook 2002 SP2)

    I am having a similiar issue at our office and was hoping someone has since found a solution. Our first Outlook 2002 user in the office does NOT want to change accounts when replying! Please help!

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Default email account behavior (Outlook 2002 SP2)

    I don't have an answer, but there is an "Internet Account" field stored in an e-mail that, presumably, tracks the incoming account. If you open a message and choose Tools > Forms > Design this Form > click the All Fields tab > choose All Mail Fields in the drop-down, you may see something there (I don't, but in Corporate Workgroup mode of Outlook 2000, I think it is supposed to be blank).

    There is no property of the MailItem object that would let you change this in code, even in your reply. But maybe there is a "back door" somewhere?? Just deleting it probably would cause Outlook to default to your default account, which sounds like what the original poster wanted.

  4. #4
    Star Lounger
    Join Date
    Feb 2003
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    53
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Default email account behavior (Outlook 2002 SP2)

    Not so hard to fix in code for your scenario, because you always want to use the same outgoing account.

    On my machine, I created emails from the account I want to use, and recorded the values for the following two MAPI properties 0x8201 (account name), and 0x8202 (return address, I think).
    Now I put create some code to catch the reply event, and on reply change those properties to those values. Screen display looks wrong until you save/close/reopen, but even without that, the setting is there.

  5. #5
    New Lounger
    Join Date
    Feb 2003
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Default email account behavior (Outlook 2002 SP2)

    I apologize for souding like a moron, but how do you do this? It sounds like it is easy enough, but I have little to no experience in coding and do not know where to begin!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •