Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Oct 2002
    Location
    Lakewood, New Jersey, USA
    Posts
    187
    Thanks
    0
    Thanked 0 Times in 0 Posts

    trouble with linked, embedded chart (Access 97/2k)

    I have an MS Graph 97 Chart in a report in an Access 2k database (recently converted from 97). The report is based on a select query and the graph, on a cross-tab query. I can't seem to be able to create a link between two fields in the graph's query and two fields on the report. If I click on the build icon next the LinkChildFields/LinkMasterFields textbox in the properties sheet, I get the message: can't build a link between unbound forms. I tried putting the fields that I want to link to into the query as criteria (e.g. [reports]![rptMyReport].expID) but access won't recognize these as valid fields. If anyone can help, I'm at a loss!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: trouble with linked, embedded chart (Access 97/2k)

    (a) In some cases, the builder won't allow you to define the child and master link fields, but you will still be able to set them manually. If you want to link on two fields, enter them separated by a semicolon, e.g.

    FieldA;FieldB

    where FieldA and FieldB are the names of the fields. The order must be the same for the child and master link fields.

    ([img]/forums/images/smilies/cool.gif[/img] When you want to link using criteria in the crosstab query, you must leave the child and master link fields clear. You must refer to the name of controls on the report, not to fields in its record source, for example
    Reports!rptMyReport!txtExpID

  3. #3
    2 Star Lounger
    Join Date
    Oct 2002
    Location
    Lakewood, New Jersey, USA
    Posts
    187
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: trouble with linked, embedded chart (Access 97/2k)

    I tried leaving the child and master link fields clear and referring to the names of the controls on the report in the crosstab query. ie. I added the "child" fields to the query, set their "Total" value to "Where" and set the criteria to: [Reports]![rptMyReport]![txtLetterCode]. txtLetterCode exists on the report, but when I try to print preview the report, I get the message that the Access jet engine doesn't recognize it as a valid field name. HELP Please!!!!!!!!!

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: trouble with linked, embedded chart (Access 97/2k)

    You have to let Access know what kind of parameters you are using.

    Open the query in design view, and select Query/Parameters...
    In the first row, under Parameter, enter [Reports]![rptMyReport]![txtLetterCode], and under Data Type, select the appropriate type - probably Text.
    The text under Parameter must be exactly the same as the text in the Criteria row of the query design.
    Do the same for the other link field.

  5. #5
    2 Star Lounger
    Join Date
    Oct 2002
    Location
    Lakewood, New Jersey, USA
    Posts
    187
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: trouble with linked, embedded chart (Access 97/2k)

    Thank you, Hans!!!!!!!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •