Results 1 to 4 of 4
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Wetherby, Yorkshire, England
    Posts
    283
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Error message on Open (A2K sr1)

    Out of the blue my database has just started coming up with this message when I open it. I've made no fundamental changes to it and the only other changes I can think of were some minor tweaks in X_Setup, none of which had anything to do with Ms Access:

    Cannot find the file 'C:My Databasefile (full path of specific db)' (or one of its components). Make sure the path and filename are correct and that all required libraries are available.

    I've tried checking for missing references but all seems well, and the DB actually opens and performs. Any ideas anyone?

    Peter

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error message on Open (A2K sr1)

    Do you really get the complete name? Sometimes this error occurs when there is a space in the path or file name, but then, the error message would display only the part of the full path+name up to (or from) the space.

    Does the error occur when you open the database:
    (a) From within Access
    ([img]/forums/images/smilies/cool.gif[/img] From the Explorer (directly opening the .mdb itself)
    From the Explorer (using a shortcut)

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Wetherby, Yorkshire, England
    Posts
    283
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error message on Open (A2K sr1)

    Hans
    The db is several years old and has never changed name or directory. The only space is between 'My' and 'Documents'.
    It doesn't happen on opening thro Access but does from explorer and a Desktop Shortcut.
    Peter

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error message on Open (A2K sr1)

    Peter,

    Make sure that the target of the shortcut is surrounded with quotes:
    "C:My DocumentsAccessMyDatabase.mdb"

    Also, in Windows Explorer, select View/Folder Options... or Tools/Folder Options...
    Select the File Types tab.
    In the list, select Microsoft Access Database.
    Click Edit...
    In the list of Actions, select Open.
    Click Edit...
    The box with "Application used to perform action" should contain something like

    <font face="Georgia">"C:Program FilesMicrosoft OfficeOfficemsaccess.exe" /NOSTARTUP "%1"</font face=georgia>

    The path to msaccess.exe will probably be different, but it is important that both the application path (....msaccess.exe) and the file to be opened (%1) have quotes around them

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •