Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    New Zealand
    Posts
    541
    Thanks
    1
    Thanked 0 Times in 0 Posts

    File Associations

    I double-clicked a .dat file in Explorer and the Open With window came up. I chose Wordpad and neglected to uncheck the box "Always use this program". Now it uses Wordpad every time. I have tried to edit this, but am unable to as I must put in a path to a program. Is there any way I can change things so the Open With window comes up? Incidentally, I know I can Shift-right click to get the option.

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: File Associations

    Find a .dat file, right click, select open with, select WordPad and then make sure that the check mark is NOT there and then click ok. Close the file and check it out, make sure it worked.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    New Zealand
    Posts
    541
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File Associations

    No, this didn't work. Dat files now open automatically with Wordpad. When I double-click a .dat file I want the Open With window to open so I can choose which program to open it with.

  4. #4
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    You didn't state exactly which version of Windows you're on, but they're all fairly similar in methodology, so you may have to poke a little tiny bit - there are other ways to be sure but these are sure to get you in the place you need to be to remove the file extension's association with Wordpad.

    Open an Explorer window.

    For Windows 95, 98, or NT 4, click on View and then Folder Options.
    For Windows ME, 2000, and XP, click on Tools and then Folder Options.

    Next, click on the File Types tab. Locate the file extension (DAT). You need to change the details for this extension - in each flavor of Windows with various permutations of Internet Explorer getting there is a little different. On both 2000 and XP, which are all I have to test with currently, you need to click on Advanced. The other versions of Windows have a similar box with a different caption. If memory serves, it reads something like "change."

    In the list of Actions, highlight each entry and then click on the Delete button. These are the options that appear in the context menu. The bold entry, the default, is the action taken when you open the file in Explorer with a double click (or single if that's enabled).

    Click on OK all the way out of there. You've just removed the associations for this file type, and now that Windows doesn't know what default action to take, it will prompt you the next time you try.

    Hope that helps - post back if you have any problems!
    -Mark

  5. #5
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: File Associations

    I wonder if you missed what Dave said? If you RIGHT-CLICK a file that already has an association, you should still get, not only the OPEN choice but OPEN WITH and a flyout menu. That menu should have CHOOSE PROGRAM on it, at least mine does.

  6. #6
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: File Associations

    Correction: in versions of Windows previous to XP you need Shift + right-click to bring "Open with..." option.

  7. #7
    5 Star Lounger
    Join Date
    Jul 2002
    Location
    Toronto, Ontario, Canada
    Posts
    1,139
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    In WIn2K you don't need the shift to get teh Open With... Option either
    --
    Bryan Carbonnell - Toronto <img src=/S/flags/Ontario.gif border=0 alt=Ontario width=30 height=18> <img src=/S/flags/Canada.gif border=0 alt=Canada width=30 height=18>
    Unfortunately common sense isn't so common!!
    Visit my website for useful Word, Excel and Access code, templates and Add-Ins

  8. #8
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    New Zealand
    Posts
    541
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File Associations

    I am using Windows 98SE. I followed your instructions and removed the OPEN instruction from the list of actions. Now double-clicking on a .dat file has no effect at all, nothing happens, it does not prompt me. The only way to open it is to Shift+right-click which brings up Open With and go from there. I want to be able to double-click a .dat file and have the Open With dialogue box come up as it did before.

  9. #9
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    New Zealand
    Posts
    541
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File Associations

    I am aware that Shift+Right-click brings up a menu containing Open With. I am trying to restore to the previous situation where double-clicking brought up the Open With dialogue box immediately.

  10. #10
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    I highly recommend modifying the registry to fix this issue. What you presently have is a File Extension that leads to a dead end Association. Therefore, Windows does nothing when you double-click a .dat file.

    You need to DELETE the .dat extension from your registry. This way, Windows believes this is a "new" file extension that it has not seen before, and THEN it will offer you the Open With... box.

    This is actually very simple:

    1) Open regedit.
    2) Drill down to HKEY_CLASSES_ROOT.DAT.
    3) Right-click on the .DAT registry key in the left pane.
    4) Select Delete.
    5) Select Yes, you are sure.

    This should do it.
    Attached Images Attached Images

  11. #11
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Of course, one would be doing the smart thing to <big>export the registry key so there is a backup</big> before deleting anything contained therein. <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

    This is what the Associations box should be doing, eliminating the need to poke in the Registry.
    -Mark

  12. #12
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Sorry, Mark -- but I have to disagree on both points. The Associations box will not take care of this problem. Philkiwi already tried that, and it is not the solution.

    The reason is because the Associations box is only working on the "file type" key and not the "file extension" key. Philkiwi has tried to remove the "Open" association by editing the Folder Options | File Type Associations box. This will correctly remove the shellopencommand entry for the "HKCRDAT_auto_file" key. BUT, this is not the solution to his problem.

    You can only fix this problem by eliminating the file extension key. This involves removing the HKCR.DAT key completely.

    There is NO reason to back up this key before he removes it. Why:

    1) The key is VERY simplistic and could be recreated in seconds. The ONLY function of the HKCR/.DAT is to point to the HKCRDAT_auto_file key.

    2) Both of these keys were inadvertently created by Philkiwi when he forgot to remove the "Always use..." box. By deleting these keys we are only restoring his registry back to the state it was in prior to his regretted action.

    Therefore, I see no reason to be overly concerned about deleting this key.

    HOWEVER, I understand your point -- backing up is always best. BUT, in this case, it is really not necessary...

  13. #13
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    You're entitled to disagree. <img src=/S/smile.gif border=0 alt=smile width=15 height=15> As William Wrigley once said...'When two men in business always agree, one of them is unnecessary.'

    I've been burned one too many times by a "harmless change" to ever think differently, especially when it only takes a few seconds to cover your butt. And the exported key costs you nothing in disk space.
    -Mark

  14. #14
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    New Zealand
    Posts
    541
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Excellent!! Thank you, R2, that is just the solution I was looking for. Incidentally, is there any way of having the OpenWith dialogue box open without the "Always open with this program" box checked? This is how I got into this strife in the first place, neglecting to uncheck it.

  15. #15
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Hmmm... good question, but I think the answer is no. Or more appropriately, not without modifying the Application Extension responsible for the Open With... box.

    I don't think MS put this as an option in the registry. The way Windows thinks is this: whenever it encounters a "new" file extension (i.e., one that is not 'registered' under the HKCR hive), it thinks you MUST want to choose a default program to associate with this extension. Therefore, the default Open With... box for an unknown extension has that box checked.

    I can look into this further, but I don't expect to find a 'switch' that controls this.
    _______________

    Mark, you are right about it taking minimal time and space, but I think your post implies that I was carelessly recommending Philkiwi delete some important registry key.

    There was nothing careless about my recommendation. I believe it was well thought out and appropriate for this situation JMHO.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •