Results 1 to 3 of 3
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Manchester, Gtr Manchester, England
    Posts
    299
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Report loses page setup (2000 Sr 1)

    I have a database with a particularly unusual sized report (about 22.5 inches by 17 inches), hence the page setup is set to print to a specific printer which is then configured to use a custom sheet size.

    When attempting to print, users keep getting errors akin to:

    The document was previously formatted for the printer printserverprintername' on Ne00, but that printer isn't availble. Does you want to use the default printer printserverdefaultprintername on Ne03:?

    In all case the specific printer is available and users are able to print a windows test page.

    To try to recreate the error I deleted the printer from my pc and the error, whilst similar, states the correct name for the port instead of Ne00 (see attached screenshot).

    Any ideas, this is driving us crazy. I have no idea whether its solely down to Access or whether the Windows OS is involved. Out network invloves a single Windows 2000 domain, where users have roaming profiles and use Citrix to access apllications. The printers are network devices shared by a print servcies.
    Attached Images Attached Images

  2. #2
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    352
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Report loses page setup (2000 Sr 1)

    It is probably a windows issue. The printer name or path is specified differently on the different computers and Access therefore cannot recognise it. This could occur if it is a local printer on your PC but a network printer for the others. Or because it is on an automatically allocated network port. For each machine this would depend on the order all printers are set up.
    David Grugeon
    Brisbane Australia

  3. #3
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Report loses page setup (2000 Sr 1)

    In Access 2000 and earlier versions, you must have a printer installed on your machine (a Windows printer, that is, not necessarily one connected physically) in order to design or preview reports, let alone print them. When the report is saved in design view, the printer settings are saved with it. If you try to run it on a machine that doesn't have that particular printer/driver installed, you'll receive the message you've been seeing. Since the printer path is saved with the rest of the settings, all machines would have to use the same mapping to that printer in order to avoid getting the message. The problem is partly Access, since it saves the hardcoded path the report was formatted for, and partly the network mappings which may be controlled by the individual user or by your network configuration. It isn't a Windows issue per se.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •