Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    SP 1 prevents Auto login (IE 6, SP 1)

    Apparently, SP 1 breaks the automatic login to sites.

    On a Win 2000 SP 3 system with IE 6 SP 1, the password is either not getting saved, or it is not automatically logging me in.

    On a Win 2000 SP 2 system with IE 5.5, I installed IE 6. And was able to auto login.
    However, I then installed IE 6 SP 1 and can no longer auto login.

    Hopefully, this will be remedied in an SP 2?
    When is such critter expected to be born?

    Is there a workaround?

  2. #2
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    Howard,
    I've come across this before where the security settings have been reset.
    Tools > Internet Options > Security >
    Check what setting you have for User Authentication - it may have been changed to "Anonymous logon" which will be rejected.
    Attached Images Attached Images
    • File Type: gif x.gif (12.6 KB, 0 views)

  3. #3
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    As a side note...
    This may also be related to the Cookie access of the site in question. If a site cannot access it's cookie, it will not automatically log you back in.

  4. #4
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    It's set to "Automatic logon only in Intranet zone".

    That doesn't sound right.

  5. #5
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    The cookie is there.

    I think SP 1 did something, because afteri nstalling IE 6 over IE 5.5 on another boot system, I was automatically logged in. So it was able to access the cookie.
    A few minutes later, I installed SP 1 and then was not automatically logged in.

  6. #6
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    It certainly seems like SP-1 is the culprit. Just because a cookie is there does not necessarily mean the site can access it.... especially not with IE6.

    Is the site in your Trusted sites zone? One silly thing that IE6sp1 did was reset the "Require server verification (https://)..." box in your Trusted sites.

    Might be grasping for straws, but... check it out.

  7. #7
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    I have no Trusted sites, I trust nobody!

    The site was able to log me in when I used IE 6, but not when I updated to SP 1, so the cookie must have been OK.

  8. #8
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    I am just trying to come up with something that IE6sp1 might have done to cause this. You are the first person that I recall mentioning something like this...

    Besides replacing many of the application extension files that are used by IE, these are some of the other things that IE6sp1 did:

    1) Created the "Hyperlinking ProxyStub Factory" and registered "hlinkprx.dll" (Microsoft Hyperlinking interfaces) -- function unknown.
    2) Created the "MS.XSLPatternFactory" and registered "msxml3.dll" (MSXML 3.0 SP 3) -- likely used for creating XSL style sheets.
    3) Removed the "Intenet.PopupMenu" object type as well as the related "iemenu.ocx" ActiveX control.
    4) Set the Kill Bit set on the "Microsoft Smart Card Enrollment (ActiveX) Control" -- which prevented this control from deleting Digital Certificates.
    5) Replaced the check in the box that says: Require server verification (https for all sites in this zone in the Trusted sites.
    6) Modified the Internet zone Security option number 1206 to "prohibit the given action". However, I can find no documentation on what this "given action" is...

    I am not sure ANY of that helps you, but just in case somethig JUMPS out at you.

    Would you consider transiently placing the site in question in your Trusted zone??

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    > It's set to "Automatic logon only in Intranet zone".

    I like that setting. I don't want my NT credentials being sent to NT servers outside my domain just because they ask for them. If this is a home PC, then that isn't an issue, I guess.

  10. #10
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    Hi Jefferson:
    Doesn't that option mean that your information isn't sent outside your domain? I thought that the "Automatic logon with current username & password" option is the one that sends it outside your domain.

  11. #11
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    Today, I tried another forum.

    The forum has two flavors:

    1. An archived version, for which I have a bookmark set which still does automatically log me in.
    2. The new version of the forum, which used to auto log me in, now does not.

    Perhaps, IE 6 SP 1 has done something to the way cookies are being interpreted?

    I won't put anything in the Trusted zone, heck, sometimes I wonder if I can trust me and myself, and I expect that me and myself feel likewise.

  12. #12
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    That confuses me too.

  13. #13
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    Yes. I guess I left out a transitional phrase in my post. I agree with you 100%.

  14. #14
    2 Star Lounger
    Join Date
    May 2001
    Location
    Monte Sereno, California, USA
    Posts
    137
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    WIN 98 SE, SR1
    I am having a similar problem with just my Hotmail Login. Others such as Yahoo still work fine.
    For years I have been using the stored ID & Password feature of WinIE and found it handy to login quickly and get rid of all that spam in my inbox andf junk mail.
    After my udate from 5.5 to 6, when I use my Favorites Hotmail Login, I get sent to a .Net Passport Screen with a "Sign in Failure" message. Then I have to reenter both ID and PW.
    Is this a new "feature" of V6?

    Serious question.
    Is there some way to reset these stored ID & Password paraments?
    or will deleting the "Favorites" entry eliminate the object all together?

    Ray A.

  15. #15
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: SP 1 prevents Auto login (IE 6, SP 1)

    You can clear the autocomplete entries by goin to "Tools, Internet Optons" and the the "Content" tab and then select the "AutoComplete" buton.
    Attached Images Attached Images

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •