Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Prevent auto view of Attachments (OE 6)

    When I receive an e-mail and click on it in the Inbox, it opens another window so I may view the message. However, if I receive an e-mail with no entry in the body and there are attachments, it automatically loads all the attachments (in this case, JPG images) in the window.

    Is there a means for preventing this from occurring, especially in the event there is nothing contained (which you would not know until selecting) in the body of the e-mail??

  2. #2
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Roanoke area, Virginia, USA
    Posts
    3,729
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    you can't prevent inline images from displaying. if you have the latest OE and IE builds, iframes are disabled in email and potentially dangerous attachment types are blocked.

  3. #3
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    MJ ~

    When you say 'inline' do you mean images that are in the body? If so, this is not to which I was referring.

    I received an e-mail; I clicked on it to view the message as one normally would and a separate window opens; there was no text or message in the body and one would not know this until one clicked on the message for viewing; the images that are attached became automatically viewable in the body. I don't think that should be the case, should it?

    In my other e-mail clients, the message comes up, I click on it, the body shows no message or text and thus a blank area and the images which are attached must be individually opened or saved. Isn't there a means of having OE do the same?

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Prevent auto view of Attachments (OE 6)

    Since there has been some new releases for AOL and MSN I have noticed that some email will now include the inbedded as well as a attched copy. This may be what you are seeing.


    Also define "e-mail clients"?

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  5. #5
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    Hi, Dave ~

    This is happening in Lookout Express [sic]. The attachments appeared in the area where the text of the message would normally appear but were not embedded initially, so this is something OE is doing.

    In the other clients, Eudora and Juno, the very same e-mail appears as a nomal window with a blank body since there was no text message and the attachments were attached as intended and accessed as one normally would by clicking on such and selecting 'Open' or 'Save'.

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Prevent auto view of Attachments (OE 6)

    Give us a screen shot, I do NOT use OE I use Outlook 2002.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  7. #7
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Roanoke area, Virginia, USA
    Posts
    3,729
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    Inline = if someone sends you a jpg or gif on a plain text message, it is normally visible at the end of the message - you don't need to open it in an image viewer.

    it sounds more like an iframe or embedded html image - these would load as soon as the message is selected in preview or when opened (if you don't have preview on).

    Check the message source - file | properties | details tab | source - plain text will say: Content-Type: text/plain; charset=iso-8859-1, html will have:
    This is a multi-part message in MIME format.

    ------=_NextPart_000_26E6_01C29C57.F24DFBC0
    Content-Type: text/plain;
    charset="iso-8859-1"

    and later in the message have:

    ------=_NextPart_000_26E6_01C29C57.F24DFBC0
    Content-Type: text/html;
    charset="iso-8859-1"
    Content-Transfer-Encoding: quoted-printable

    if you see a CID, it's embedded in an iframe and you need to get the latest IE patches. The iframe patch has been out for about 6 months now and it will stop messages from opening attachments - klez uses iframes. (sorry, no samples of a CID - my AV scanner kills them - the header has Content-Type: multipart/alternative; boundary=MzvoHEd16hQK0f3LHDc8862 and the CID will have something like the boundry code in it)

  8. #8
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    As requested...

  9. #9
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    Here is the source:

    <pre>To: bruce@krymow.com
    Date: Sat, 7 Dec 2002 02:18:08 -0500
    Message-ID: <20021207.021809.244.14.>
    X-Mailer: Juno 5.0.33
    MIME-Version: 1.0
    Content-Type: multipart/mixed; boundary=--__JNP_000_1404.0f2c.4bde
    From: SweetCheeks <sweetcheeks@juno.com>
    X-UIDL: Td>"!ZM;"!d%U!!R]]"!

    This message is in MIME format.
    ----__JNP_000_1404.0f2c.4bde
    Content-Type: text/plain; charset=us-ascii
    Content-Transfer-Encoding: 7bit</pre>

    I do not see CID. This does not appear to be an iframe and is definitely not embedded html. The images were attached and not sent inline. When this exact same e-mail is viewed in Eudora or Juno, it shows a blank e-mail message body since no text was entered and the attached images must be accessed in the conventional fashion.

    Now, if this very exact e-mail is sent with just one word typed into the e-mail body, then OE will not open the attachments as per the above screenshot and works like it should as do the other aforementioned clients.

    Any idea as to why it opens the attachments when no text in the e-mail body? Any way to prevent it from opening attachments until I specifically choose to do so as one would normally?? <img src=/S/confused.gif border=0 alt=confused width=15 height=20>

  10. #10
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Roanoke area, Virginia, USA
    Posts
    3,729
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    According to this screenshot, they aren't opening in image viewer programs, but inline in OE. this is normal behavoir and not dangerous.

  11. #11
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    Correct, they are not opening in any image viewer programs and are opening within OE, but I would prefer they did not automatically open.

    If the message area were to contain the sole word 'Hi', they would not open until I selected one or all. How does one keep them from opening when no message is entered?

  12. #12
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Roanoke area, Virginia, USA
    Posts
    3,729
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    there is something that is preventing them from displaying inline in that case - because normally, they would follow the text and be displayed at theend of the message.

    if the message is html format and they are not embedded, i'm not sure if they display inline or not.... however, it's not something you control - the sender controls that.

  13. #13
    4 Star Lounger
    Join Date
    May 2002
    Location
    Australia
    Posts
    549
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    If I understand what you are saying correctly, then the message that should appear within the email body when attachments are not wanted to be seen is "The Outlook Express

  14. #14
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent auto view of Attachments (OE 6)

    I don't know to what you are referring when you mention the Outlook Express

  15. #15
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Prevent auto view of Attachments (OE 6)

    You shouldn't have scripting enabled in e-mail. Name one good use for it. Seeing pictures is the least of your worries!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •