Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Feb 2001
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts

    JVM Problems (IE 6.0 XPSP1)

    Before I break down and install Opera or something, can someone explain to me why every time I go to a Java type web site it tells me I have to install JVM for Microsoft? I've installed SP1 for XP (pro) and I've recently installed the Microsoft hotfix for the VM. When I type jview at the command prompt I get the version number of my JVM as 5.00.3809, so according to the Knowledge base it's the most recent. My permissions in IE are untouched, i tried setting Java permissions to medium instead of the default custom, didn't matter. I've always had problems running JVM, before or after service packs and hotfixes. I always considered myself good with computers, I feel like a quivering idiot. Maybe it's the moon phase...

    Thanks
    Tim

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: JVM Problems (IE 6.0 XPSP1)

    Tim, Did you do all the installs as a user with administrative rights? Have you checked IE Tools | Internet Options | Advanced that the JVM is enabled?


    Joe
    Attached Images Attached Images
    Joe

  3. #3
    New Lounger
    Join Date
    Feb 2001
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: JVM Problems (IE 6.0 XPSP1)

    thanks for your reply-slick screenshot too....Had that option checked already, and I also checked the Java console, rebooted and tried that. Still no go. Hmmmmm....

    Tim

  4. #4
    5 Star Lounger
    Join Date
    Dec 2002
    Location
    Perth, Western Australia, Australia
    Posts
    730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: JVM Problems (IE 6.0 XPSP1)

    I fixed my Java probs with the genuine article, from Sun. Since you know what you're up to, probably best to do the manual download.

    I wasted hours with my OEM XP SP1 (Home) trying to work what was going on with Java. According to MS KB Java is included with SP1, but I couldn't see any evidence it was installed. A hunt throught docs on the CD told me that Java was there, but again I couldn't find a hint of it on the CD either. Attempts to download it from the MS Updates site failed because the link pointed nowhere (a msg to say that the item was no longer available). Further searches in KB led to docs that said Java had to be dropped from XP because Sun was being silly with legal action, but had could be downloaded form MS Updates, and was again invluded with SP1. Foolishly I persisted with more attempts trying to get it from MS <img src=/S/brickwall.gif border=0 alt=brickwall width=25 height=15> .

    Luckily I woke up in the end <img src=/S/doh.gif border=0 alt=doh width=15 height=15>, and remembered where Java came from. Apart from the real Java VM, their site also gives a slightly different version of the shenanigans with MS.
    <font face="Comic Sans MS" color="blue">TimOz</font>
    <img src=/S/flags/Finland.gif border=0 alt=Finland width=30 height=18> <img src=/S/flags/Australia.gif border=0 alt=Australia width=30 height=18>

  5. #5
    New Lounger
    Join Date
    Feb 2001
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: JVM Problems (IE 6.0 XPSP1)

    Yep, that works. One gets so wrapped up in a MS world you can almost forget other people write software too. The stubborn fool in me wants to figure out what is wrong with the MS VM, the realist in me wants to go read a book to my sweet adorable childern. Thanks for the pointer.

    Tim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •