Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Jan 2002
    Location
    Scotland, Midlothian, Scotland
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    OpenRecordSet won't work after splitting database (Access97/SR2)

    Dear all
    Help once again please.
    Had a database working fine but have decided to split it to a front end / back end model with the tables on the server and the forms and objects with the user. Have found that my code crashes on the line

    Set rst = dbs.OpenRecordset("AppealsOfficers")

    This now gives an error message

    "Method or data member not found"

    Examination of the on line help seggests that I need to set up a tabledef for the object. Unfortunately the help does not help me find out how to extract and write data to the linked table. I have been unable to find an adequate explanation as to how Access works with linked files that allows me to work it out.

    Any help would be great.

    Many thanks in advance - you have always come up with the goods so far

  2. #2
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Newbury, Berkshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: OpenRecordSet won't work after splitting database (Access97/SR2)

    If the DB was working fine as one database and the problem only manifested itself when you split the database into back-end front-end, then I can think of two things that might cause this.

    1) Have you checked the references in your new DB?
    2) It is possible that your database was corrupted before you split it, it is quite common for a DB to work OK, but problems mysteriously manifests themselves when you make major alterations. The solution is to use the decompile Switch in the command line and decompile the DB before you split it, or try decompiling both of the new databases.

  3. #3
    Lounger
    Join Date
    Jan 2002
    Location
    Scotland, Midlothian, Scotland
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: OpenRecordSet won't work after splitting database (Access97/SR2)

    Thanks Rupert
    Silly of me I should have checked that. I just expected that the refereneces would be preserved when the database was split. Have corrected the references in the 'backend' and it not proceeds past this point.

    Many thanks for the very fast response
    Have a good new year when it comes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •