Results 1 to 2 of 2
  1. #1
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    AutoFill Form (Access 2000)

    I have a form set up to autofill two fields from the last record. I used the procedure from Microsoft Knowledge base article 210236 which calls a function called AutoFillNewRecord. The function allows to fill all the fields or selected fields using an unbound textbox in which the Default Values property is set to limit the list to only those fields you want to autofill. My problem is that the function does not seem to work when I limit the list. If I have it fill in everything (by not using the unbound textbox), the function works fine. So clearly the problem seems to be in hooking into the information stored in the textbox.

    I have followed the directions in the Knowledge Base article to the letter and have seen a post in this forum from last May from another lounger who used it with success, so I am at a loss where else to troubleshoot.

    Any suggestions would be greatly appreciated.

    PeterN

  2. #2
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoFill Form (Access 2000)

    Well...

    Aren't I embarrassed. I had another look after some quiet time away from the monitor and realized I had been entering the name of the control sources "ContributionDate" and "DepositDescription" instead of the field names on the form "Date" and "DepositID". Once I put in the right info, it worked like a charm!

    Garbage in, garbage out.
    <img src=/S/stupidme.gif border=0 alt=stupidme width=30 height=30>

    PeterN

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •