Results 1 to 6 of 6
  1. #1
    New Lounger
    Join Date
    Sep 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    VS.NET web forms (VB.NET)

    I have been using VB.NET successfully with Windows forms and am starting a web forms application using ASP.NET project option. IIS was installed then VS.NET re-installed. When a project is debugged using Debug/Start the following error message appears:
    Unable to start debugging on the web server. Server does not support debugging ASP.NET or ATL Server applications. Run setup to install .NET server components (checked that - all installed). If setup has been run verify that a valid URL has been specified (not sure how to do that).
    Debug/Start without debugging runs but displays a blank web form (which should display some controls).

    Has anyone any ideas to fix this?

    Thanks
    GraemeC

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: VS.NET web forms (VB.NET)

    A couple of questions for you...

    1) I trust that you have the .NET Framework installed properly (sine you've used VB.NET already). You may want to double-check to make sure you have IIS correctly installed, then re-install the .NET Framework (and SP update)
    2) I also trust that you're using the .ASPX extension (emphasis on the "X") rather than .ASP.... Without the X, the page is processed by the "Classic ASP" DLL, and the X is required in order to be processed by .NET.

    Other than that, I'm not aware of any strange issued that need attention when installing. It's worked fine for me.

    Hope this helps!

  3. #3
    New Lounger
    Join Date
    Sep 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: VS.NET web forms (VB.NET)

    Hi Mark

    Thanks for the suggestions. VB.NET worked perfectly with projects based on windows forms. The IIS hadn't been loaded initially and that was apparent when I started. The server appears to have loaded OK (no errors) and I then re-installed VS.NET as some of the help files indicated that IIS must be loaded before VS.NET. I am using the ASPX extension so that's not an issue. All the required files seem to be created when the solution and project are defined. As a last resort I will uninstall both VS.NET and IIS and re-install again and hope that solves the problem.

    Graeme

  4. #4
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: VS.NET web forms (VB.NET)

    I just remembered something else that may be causing the problem...

    There's a setting in IIS that allows (or denies) server debugging. Although, I'm not sure if that has any relation to .NET. It's certainly worth a try.

    Open the IIS management console, and navigate to the Web folder that you're working with.
    Right-click the appropriate folder, select Properties.
    On the "Virtual Directory" tab you'll see a section at the bottom called "Application Settings".
    Click the Configuration button, then select the Debugging tab.
    Make sure the "Enable ASP server-side script debugging" is checked.
    Click "OK" until everything is closed.

    I'll keep thinking to see if anything else comes up in the meantime.

    Hope this helps

  5. #5
    New Lounger
    Join Date
    Sep 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: VS.NET web forms (VB.NET)

    Mark, Sorry about the delay. This has been a frustrating exercise. However the problem is now solved.

    First I did an uninstall , reinstall of IIS and VS.NET which had no effect. I then followed up on your suggestions which were part of the answer. The final step which worked was:
    1 Open IIS (Control Panel, Administrative Tools, Internet Information Services)
    2 Expand the left pane, click the Web Sites folder in left pane (or combination - seems to be a few ways to do it) to show Default Web Site folder in right pane
    3 Right click Default Web Sites, select properties
    4 Select Home Directory tab
    5 Under Local Path: Check - Script source access, Read and Write
    6 Apply, OK
    7 right click Default Web Site again, select Stop (if running), then do this again to select Start (should end up with State = Running) for Default Web Site, I don't know if this is really needed for the settings "to take")
    8 Close IIS

    Then both Debug/Start and Debug/Start without debugging displayed the form as expected. It may be more appropriate or better to do this from the Web Sites folder properties but haven't yet tested that. I'm sure there are plenty of gurus out there who can explain the finer details but the basic cause seems to be that my install resulted in default settings different from those when you installed. I have no explanation for that. I'm just a happy little programmer with gray hair.

    Graeme

  6. #6
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: VS.NET web forms (VB.NET)

    Hi Graeme,

    I'm glad to hear you got it working. I should have thought about the default Read/Write settings. You're right - somehow your defaults are different than mine - perhaps because I've changed mine somewhere along the way. It's good to hear what will fix the issue if it comes up again. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •