Results 1 to 7 of 7
  1. #1
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Porthcawl, Mid Glamorgan, Wales
    Posts
    107
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IIS & Access rights

    I am running Windows XPPro NTFS on a home network using a workgroup. I have several web sites and have installed IIS on one of the machines to allow me to preview my sites before I publish them to my web hst servers.

    The problem I have is that I get an error 403.1 Access denied and try as I might, I cannot 'see' the sites on my intranet.

    I have tried 'playing' with the directory access rights but nothing. To make life easier at home we don't bother with passwords since none of us has any secrets. They are blank. I am of course an administrator of the machine.

    Any ideas?

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IIS & Access rights

    Hi Doug,

    I take it you're using the proper URL to access the site on your server machine (i.e. http://Server/WebFolder).

    Assuming that's the case, there's a setting in IIS that's probably causing your problem. (See Attached Image)

    Open the IIS management console, navigate to the desired folder(s).
    Right-Click, select Properties.
    Click the "Directory Security" tab.
    In the top group ("Anonymous Access and authentication control"), click the Edit button.
    Check the box to allow Anonymous access (at the top). Also leave the "Allow IIS to control password" checked.

    If that doesn't work, you may also want to make sure that your web folders have proper permissions for the username listed as the Anonymous username (mine is "IUSR_ComputerName").

    Hope this helps!
    Attached Images Attached Images

  3. #3
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Porthcawl, Mid Glamorgan, Wales
    Posts
    107
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IIS & Access rights

    Thanks for the reply Mark;
    >>I take it you're using the proper URL to access the site on your server machine (i.e. http://Server/WebFolder).
    Mine is http://pc2/golf-in-england.com

    >>Check the box to allow Anonymous access (at the top). Also leave the "Allow IIS to control password" checked.
    Same as you.

    >>"IUSR_ComputerName"
    >>IUSR_PC2. I think this is where I came unstuck. When I get home tonight I'll check these user rights. I'm pretty sure I haven't set permissions for IUSR_PC2, just for my own user name.

    Will let you know!

  4. #4
    4 Star Lounger
    Join Date
    Aug 2002
    Location
    Dallas, Texas, USA
    Posts
    594
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IIS & Access rights

    By default the IIS 'default user' should have permissions set already. However, one thing that I see overlooked in the posts so far, is that your URL's are only going to folder level. You have to setup a 'default' document to do that.

    Get into the IIS Admin window. Right click on the 'root' folder, and click properties. The tab you want is documents, which will list the 'default' documents that the IIS server looks for, when a direct page is not requested.

    You can test what I just brought up without even going into IIS's settings. Just try pulling up the page with the FULL URL, which includes the page. (ie, http://MyComputer/index.htm)

  5. #5
    2 Star Lounger
    Join Date
    Apr 2001
    Location
    Coppell, Texas, USA
    Posts
    168
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IIS & Access rights

    I have the same setup and a test case showed the same problem. I had to do two things to get the test project working:

    1) (As MarkJ said If you get 403.1 errors viewing a web folder or page on your machine, make sure the anonymous access account has permissions to access the folders and files in NTFS (not just IIS). By default, XP's IUSR account does not have access to folders outside the web root's path. So you'll need to add IUSER_PC2 (or the PC2Users group) if you're using a Virtual Directory based on, for example, Cocuments and SettingsMy NameMy DocumentsProjectsGolf-In-The-Kingdom to preview the web.

    2) Don't use a "." (period or stop character) in the folder names. I think that once you get beyond the first single slash in the URL the stop character marks the end of path/file-name and start of file-extension. So http://pc2/golf-in-the-kingdom.com looks like a file named golf-in-the-kingdom, of type "com" in the web's root folder. Ecaping the stop (.) doesn't seem to help. No errors, just doesn't work.

    Netscape seems more sensitive to this issue too. I think IE sometimes resolved the ACL problem in the background using Challenge/Response (now called Integrated Windows Authentication). But Netscape reliably fails.

    Now then, I notice you don't have a Golf-in-Scotland.com site. Did someone else get it, or would that simply be redundant? And you have read Golf in the Kingdom, haven't you?

    HTH

  6. #6
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Porthcawl, Mid Glamorgan, Wales
    Posts
    107
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IIS & Access rights

    Thanks for the info. I haven't forgot you I just don't get much of a chance to login to this particular machine.

    Thanks also for th interest in my Webs. Golf-in-Scotland has been registered for the last 2 years, and now the next 2 by some travel company who have done zilch with it. I might offer them something for it but that doesn't sit right with me!

    What is "Golf in the Kingdom"?

    Cheers

  7. #7
    2 Star Lounger
    Join Date
    Apr 2001
    Location
    Coppell, Texas, USA
    Posts
    168
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IIS & Access rights

    Golf in the Kingdom is a book by Michael Murphy about a fictional guru (Shivas Irons) who teaches life lessons to the author through golf (or golf lessons in life, depending on how you look at it). It was recommended as a great read even for non-golfers, and I enjoyed it very much.

    I noticed Golf-in-Scotland wasn't functioning. Pitty, that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •