Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    May 2001
    Location
    indiana
    Posts
    130
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Access is not listening!! (Access 97)

    are there any circumstances where the expression "Forms!frmMainMenu.Visible = True" would ever return "False" immediately after it was executed? (basically like if access just ignored the command when it proccessed it). I have a main menu form that turns invisible when it switches to another form, then back to visible again when it the other form closes. However even though i am setting the visible property back to true, the form remains invisible. I am completely stumped here... Any help would be greatly appreciated

  2. #2
    2 Star Lounger
    Join Date
    May 2001
    Location
    indiana
    Posts
    130
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access is not listening!! (Access 97)

    Well, it looks like the problem lies in that i had the modal property of the main menu set to yes... I turned it off and things worked again.. Does anybody know why this would happen?

    Thanks

  3. #3
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Access is not listening!! (Access 97)

    I'm not quite sure what you were doing, but if the form you opened up when you hid the main menu was also modal, then you wouldn't be able to show the main menu again while the other one was visible. You can only open another modal form or make it visible if you hide or close the modal form you call it from. Basically, you're allowed one modal form active at a time because that's the nature of modal forms.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •