Results 1 to 7 of 7

Thread: Removing ICS

  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Brisbane, Australia
    Posts
    245
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Removing ICS

    I have two Win XP Home laptops that are networked and Internet Connection Sharing is enabled. I now want to use WinProxy and to install it, the ICS must be uninstalled.

    How do you remove a network connection and/or remove ICS? (Tried disabling either but does not work BTW)

    TIA, Leigh

  2. #2
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Removing ICS

    Have you tried running the Network Setup Wizard to re-define your connections? I would think that to be the easiest way.
    -Mark

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Seattle, Washington
    Posts
    320
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Removing ICS

    I just had a lot of trouble with ICS not going away even after I asked it nice. The culprit is a setting in Internet Explorer: Tools>Internet Options>Connections>LAN Settings>Automatically Detect Settings. With this box checked (which was the default when I loaded xp into my new computer) ICS kept re-appearing after I had removed it in every way I could think of. Don't know if this is what you're up against, but it had me bamboozled for a couple of hours. FWIW

    kip

  4. #4
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Brisbane, Australia
    Posts
    245
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Removing ICS

    Thanks Mark - I did look at it but couldn't see how to tell IE that it was not to invoke the ICS. I will be back on the site tomorrow (local time) and will check again and also try kip's suggestion and respond (hopefully with good news) when I am back here.

    Leigh (in retrospect, I am glad I didn't run my reply past MS Word's grammar checker!)

  5. #5
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Removing ICS

    Actually that wasn't my suggestion, but it's sound - disallow Internet Explorer from automagically detecting network settings so that it doesn't feel the need to enable ICS or anything else. I may not be of much use in this regard, as I don't use ICS - I've implemented a router and hub at home, which is much more pain than most people need, but I also don't have to worry about Windows trying to think for me when it comes to the network.
    -Mark

  6. #6
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Brisbane, Australia
    Posts
    245
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Removing ICS

    Thanks again, the update: As WinProxy would not install when there was any semblance of ICS lurking, to remove ICS I tried all the following in the order listed;
    * Pretend that the PC is not going to share (using the wizard)
    * Pretend that there is no network (by deleting the network in Network Places)
    * Re-setup a network (using the wizard)
    * Redo the ICS (and just plain forget about WinProxy!!!)

    And now all is well - just took the better part of four hours to undo all the automagically set 'settings'.

    So in all it was a combination of Mark's and kip's advice that resolved that one - thanks for your assistance. Now, back to VBE for more (hair-tearing) fun with Microsoft.

  7. #7
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Seattle, Washington
    Posts
    320
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Removing ICS

    Geez I thought the first time was tough. I just upgraded my motherboard/cpu, with a new onboard network adapter. Again, I couldn't get rid of the dang ICS for the life of me. My trick above did not work, and I looked and looked. Ran the network wizard several times, calling for no ICS (>other>network hub), but there it was again. OK so I just finally found it this time, in (deep breath) Control Panel>Network Connections>Advanced>Optional Networking Components>Networking Services>(Details)>Internet Gateway Device Discovery and Control Client (uncheck it). My Goodness Gracious, I've never been THERE before. When I first booted up the new board, the network adapter kicked in and installed itself automatically, and I'm thinking that my not having the other computer on the net up and running may have altered the settings chosen. Anyway, even though there probably isn't any harm in the way it was set up, it just bothered me. All is good now, though.

    kip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •