Results 1 to 12 of 12
  1. #1
    3 Star Lounger
    Join Date
    Jan 2002
    Location
    Texas, USA
    Posts
    273
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Recently reinstalled ME and all software and installed IE6.0. Downloaded and ran all SP's. Now, when I visit some websites, the Intall on Demand window pops up saying it has to install a component but does not name what it is trying to install. Simultaneously, I get the message that the download failed and to use IE Tools to download and install it, but of course I don't know whats missing. Under Tools/InternetOptions/Advanced, the Enable DOE is enabled.

    Any help would be greatly appreciated.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Bob,
    If you did a typical or minimal install you could uninstall and do a full reinstall. Not sure if you can change to a full install with a repair. After a full install the only install on demand you may run into is for a foreign language.

    Joe
    Joe

  3. #3
    New Lounger
    Join Date
    Jul 2002
    Location
    London
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    I get this error for the offline browsing pack which failed to install after I installed the IE6 SP1 patch from Windows Update site. I've tried uninstalling and reinstalling and always get the message that the offline browsing pack failed to install. HELP!

    Nick

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Nick,
    What kind of install did you do? Typical or 'Minimum/Custom'?

    Joe
    Joe

  5. #5
    New Lounger
    Join Date
    Jul 2002
    Location
    London
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Joe, I tried every which way: typical, minimum with offline browser pack checked and with all components checked (including those that were already installed but excluding all the language options). The outcome was always the same - did not install the offline browser pack. IE6 is working ok, albeit a little sluggish, but the offline browsing feature is inoperative and when IE6 tries to autodownload after I save a favourites for offline browsing, it comes back with the error not available for this version of windows (ME). Everything was working ok before I installed the SP1 update. So, where do I go from here?

  6. #6
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Do you have a restore point that you can go back to?

    Joe
    Joe

  7. #7
    New Lounger
    Join Date
    Jul 2002
    Location
    London
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Joe, I've never used that feature (never had reason to before). Bit reluctant to go down that route...

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Nick,
    Is the error message on install any more specific than 'failed to install'? Can you completely uninstall IE 6.0 & tehn re-install IE 6.0 SP-1 (the complete install is the full product)?

    Joe
    Joe

  9. #9
    New Lounger
    Join Date
    Jul 2002
    Location
    London
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Joe, the message is:
    "Not all components installed successfully
    - Offline Browsing Pack"

    Initially, the Advance Authoring was not installed but I followed the procedure from KBA 305963 and managed to get it installed.

    When I invoke add/remove IE6 SP1 + Internet Tools, the option to restore previous Windows version is not available. Only have choice to Add Component or Repair IE.

    When I invoke Add Component, I get the Resume Windows Update: Internet Explorer + Tools window. Running either option always fails to install the offline browsing pack.

    Nick

  10. #10
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Nick,
    I ran across this in one of the MS newsgroups for IE.

    "This worked for me, and other people have tried it with success:

    Open Windows Explorer (not Internet Explorer but Windows Explorer as in the
    file management program). From there go to C:/Program Files/Internet
    Explorer/Uninstall Information. Right click on the Uninstall Information
    folder and select Properties. Uncheck the Hidden box and then click OK or
    Apply. A confirmation screen will come up. Select the Apply changes to
    this folder, subfolders and files button. This will unhide all of the files
    in the Uninstall Information folder. You then need to move (not delete) all
    of these files to another folder that is empty. Any one will do or make a
    new temporary folder. It doesn't really matter just as long as the
    Uninstall Information folder is empty. Reboot your computer. After
    rebooting double check and make sure that the Uninstall Information folder
    is empty. You should then be able to install all of the troublesome
    components (hopefully). If everything goes well you can then move all of
    those files that you moved previously back into the Uninstall Information

    Good luck,

    Zee"

    See if that helps.

    Joe
    Joe

  11. #11
    New Lounger
    Join Date
    Jul 2002
    Location
    London
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Joe, apologies for taking a time to reply. Been busy setting up workstation. Used your suggestion and it worked! Many thanks. Incidentally, I did try to a system restore (under Windows ME) and it failed. No reason given.

    Rgds, Nick

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Install on Demand Error (IE 6.0 (no SP) on Win ME)

    Nick, No problem. Glad it worked. Hope the workstation install went smoothly.

    Joe
    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •