Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Sep 2002
    Location
    Brookings, South Dakota, USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    mail merge with a secured database (2002)

    I have a secured database accessed through a shortcut that points to the correct system.mdw. When we try to use word to send form letters based on queries with mail merge it opens the default system and then says we don't have permissions to open the database. I have tried to link the letters through access but that doesn't work either. What am I doing wrong?

  2. #2
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: mail merge with a secured database (2002)

    Mail merge attemps to start access using the default security file, so you need to use the Workgroup Admin option under Tools/Security to set the default to what you want. You may also encounter other quirks on secured databases, such as Access starting a second instance even though you had it open when you started the merge. And things can get sticky if you want to use a parameter query as the data source for your mail merge. We've got a tutorial on our web site that you might find useful.
    Wendell

  3. #3
    Lounger
    Join Date
    Sep 2002
    Location
    Brookings, South Dakota, USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: mail merge with a secured database (2002)

    Thanks Wendell, I have run into both problems you mentioned in your reply!! I've started looking through you're tutorial and it looks very informative. I may just need to do more looking but am still unable to make the mail merge work, although they did work before updating to 2002 from 2000. I'm using a front end, back end if that makes any difference. I changed the workgroup to the correct default (on both ends) that I needed but now (without asking for a password) it brings up the option to use tables that are in the front end not any that are linked to the back end, and no queries or reports are in the options. Still Stumped...

  4. #4
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: mail merge with a secured database (2002)

    I've also seen the problem you are having - it seems to be dependent on the operating system you are using. I'm running WinME (unfortunately) and see the problem, but my partner gets slightly different behavior on Win2000 and WinXP Pro, and is able to get around it because he gets an error message and can choose DDE. For what ever reason, the OLE DB interface only sees local tables, not linked tables. You might also want to look at the Woody's Access Watch we wrote with Helen Feddema on the subject if you haven't already. One trick I found out about recently is that you can activate the old Word Mail Merge helper using the menu customizations, and that may get you around the problem by letting you choose DDE as your connection method. Hope this gives you some ideas to try - I presume you are not running the merge from Access using Automation?
    Wendell

  5. #5
    Lounger
    Join Date
    Sep 2002
    Location
    Brookings, South Dakota, USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: mail merge with a secured database (2002)

    I just tried using automation, it does work but opens 2 more versions of the front end..very annoying. I'd like to change back to the old word wizard if you can give me a little more information and then I'll need to figure out how to prevent the multiple instances of the front end from opening. I'm not sure updating to XP Pro was worth all this <img src=/S/hairout.gif border=0 alt=hairout width=31 height=23>

  6. #6
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: mail merge with a secured database (2002)

    Check out <post#=210761>post 210761</post#> - that's where I first ran across it, but I haven't actually done it. Good luck.
    Wendell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •