Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Apr 2001
    Posts
    482
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Automatically detect setting (LAN) no longer works (Internet Explorer 6.0, SP1)

    I'll give my recent IE history in case something else is causing this. I installed the latest SP about a month or two ago. I then found I could not connect to work, which I found was a problem with a server at work that needed a patch. I found I could uninstall the patch and did so (I think it also brought me back to version 5.0 or 5.5 as well), but I never chose to "Clean up my IE 6 settings" as I was always prompted to do when booting into Windows 2000 because I was afraid it would take favorites, proxy settings and other preferences. Later they patched the server at work and I reinstalled 6.0 and the service patch.

    Previously I had checked the "Automatically detect settings" check box on the Local Area Network (LAN) Settings dialog (Tools > Connection tab > LAN Settings) and checked the "Use automatic configuration script" and used a script provided by my work. It worked great. When I was connected to work through VPN it detected that and prompted me for my User ID and password, as it should have. When I was not connected to work, it would simply connect to whatever sight I chose.

    Now before I connect to work I have to manual check "Use automatic configuration script" check box and uncheck it when I am done because if not I can't connect. What's messed up and what can I do about it?

    Thanks!!
    Troy

  2. #2
    4 Star Lounger
    Join Date
    Aug 2002
    Location
    Dallas, Texas, USA
    Posts
    594
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Automatically detect setting (LAN) no longer works (Internet Explorer

    Before you know it's an IE issue, you need to verify that it's not your network. Look at the 'script' setting. It should be a path and file name. For example, ours is http://wpad.marlow.com:8080/wpad.dat

    Which means it's a file called wpad.dat, which you get by hitting port 8080 on the server that translates to wpad.marlow.com. That translation can only occur in house. I can ping wpad.marlow.com in house, and I'll get an IP address, which is the IP address of our proxy. However, if I ping that outside, from the internet, it won't come up with anything, because it's not supposed to translate. Thus, the 'Automatically detect proxy' determines the proxy isn't there, and tries to just use the internet through your gateway.

    However, if for some reason, they changed that script or the server, so that it can be 'reached' from the internet, then your browser will see the proxy, yet the proxy may refuse requests from the other side. So look at your script, and when you are away from work, try to ping the server (or even put that script into your browsers Address bar, see if it brings up a file. If it does, there's your problem, if it doesn't, try to repair IE (go into the Add/Remove programs, and when you try to uninstall it, one of the options should be a repair option.

  3. #3
    4 Star Lounger
    Join Date
    Apr 2001
    Posts
    482
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Automatically detect setting (LAN) no longer works (Internet Explorer

    Thanks for your response. Although despite that great information you gave, I'm not sure it applies to my situation. If I select to use the proxy it worked fine when I tried to connect to work. What did not work is the automatic detection of whether IE needed to use the proxy or not.

    I noticed yesterday, that everything mysteriously started working again. If it happens again, I'll try the repair feature you mentioned.

    Thanks!!
    Troy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •