Results 1 to 10 of 10
  1. #1
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    369
    Thanks
    2
    Thanked 1 Time in 1 Post

    Outlook the thief (2000SP3)

    Aaargh. Ever since installing IE6SP1 outlook keeps stealing the default mail client. Every time I start Outlook express, it tells me it's not the default client, and I ask it to make itself so. It then does so (checked in IE-internet options-programs, OE options, URL:mailto and HKLM/software/clients/mail). As long as I don't open outlook, it remains the default client, but as soon as I open outlook, it steals the default back (checked in all above locations). I've scoured outlook options to see if I can find any way to stop this behaviour and i can't. Oh, and I've also run "crogfilesoemsimn.exe" /reg, and /defclient (path abbreviated). All to no avail.

    How can I stop this thieving outlook?

    thanks

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Outlook the thief (2000SP3)

    Mark, at this time I can only take a look at OL XP, but see if in OL 2k there is an option under Tools, Options, Other, to UNcheck the box "Make Outlook the default Program for E-Mail (etc.)". HTH, if not post back.
    -John ... I float in liquid gardens
    UTC -7ąDS

  3. #3
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    369
    Thanks
    2
    Thanked 1 Time in 1 Post

    Re: Outlook the thief (2000SP3)

    I'd already had a good look through the list, and didn't find any such option. I've just looked thoroughly again in every option category, and there's nothing like this. I can't find anything about it in online help either, and any articles I came across when searching for a solution all directed one to the internet explorer options to set the default email client. Everything's just got slightly weirder, in that when I opened outlook this time, then clicked on a mail link in this window (which had been opened prior to outlook, at at time when OE was still the default client), OE opened to send the message, but simultaneously informed me that it wasn't the default client!! I don't know if that was anything to do with the fact that this window was opened when it was.

    As a last resort (and because I just came across it), I tried outlook's detect and repair. It didn't change anything, though I was rather alarmed to see that the office installer was still calling itself Office 2000 SR1 professional, even though I've installed SP3 (and all office apps identify themselves as SP3).

    So, no joy. Any more suggestions? Thanks

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Outlook the thief (2000SP3)

    If Bruce K's suggestion doesn't work my last-resort recommendation is to remove all mail services you have installed in OL, I don't however know if it will run without one. (And I only have OL 2000 in Corporate mode, not IMO.)
    -John ... I float in liquid gardens
    UTC -7ąDS

  5. #5
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    369
    Thanks
    2
    Thanked 1 Time in 1 Post

    Re: Outlook the thief (2000SP3)

    Still no joy, and I'm worried by that last resort comment!

    Bruce - I cannot find any option in Outlook to set whether or not it is the default client. If I could I would use it, and I'm sure it would solve the problem. I tried changing the settings in program access and defaults, and it flopped back again as have all the other settings (interestingly Outlook wasn't even on the list - just my current email program and OE).

    John - I'd thought of that, but I don't have any email accounts set up in Outlook (I never use it for mail). I have already double checked that there's nothing there. I also have corporate setup, but only so I could control the location of my .pst file.

    The plot thickens slightly in that this setting is very volatile. If I open OE, set it as default, then open Outlook, the default client is now Outlook, but if I then close Outlook with OE still open, the default client reverts to OE. If I close OE before Outlook, the default client remains Outlook, but if I close Outlook first, the default client remains OE. The same is not true if I answer yes to wanting OE to make itself the default client. This setting is sticky until the next time Outlook is opened.

    The odd behaviour above - with a URL mailto link sometimes using OE even though it isn't default, is still happening.

    I can't help feeling that there must be a switch or reg setting to stop Outlook trying to do this. Any more ideas?

  6. #6
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook the thief (2000SP3)

    Per the instructions above.
    Attached Images Attached Images

  7. #7
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    369
    Thanks
    2
    Thanked 1 Time in 1 Post

    Re: Outlook the thief (2000SP3)

    Sorry Bruce, I'd mentioned in my first post that I'd already checked in IE-internet options-programs, and that it reflects what's going on elsewhere (ie mail program flipping between OE and Outlook). I really don't have that option in outlook, as I mention I'm using 2000sp3 - your screenshot looks like XP. Here's mine
    Attached Images Attached Images

  8. #8
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook the thief (2000SP3)

    Anything at the Office Asstance Center help? Using the "/unregserver" switch looks like it may do something useful, but what you may need to check before running "/regserver" is beyond me...

  9. #9
    3 Star Lounger
    Join Date
    Feb 2001
    Posts
    369
    Thanks
    2
    Thanked 1 Time in 1 Post

    Re: Outlook the thief (2000SP3)

    Thanks, Leif, but once again that's 2002 - there's no unregserver and regserver command line switches for OL2000. I did have a look around the site, but nothing to help me, unfortunately. I did find a /safe command line switch, which I tried in case some unknown add in was causing the problem, but the behaviour persisted. Interestingly, when I started Outlook with the /checkclient switch, after making sure I'd made OE the default client, Outlook only informed me that it was not the default client for News and Contacts - it had already grabbed the default mail status by the time the /checkclient switch cut in.

    I'm getting the feeling that this is going to be one of those marvellous MS idiosyncracies requiring living with or reinstalling, neither of which is particularly inspiring. I may try posting to the MS newsgroups, so if any of you hang out there, please don't be offended at my cross posting - I like to try in one place at a time!

    Thanks anyway

  10. #10
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook the thief (2000SP3)

    Hi, Mark P ~

    Since you've installed IE6SP1, then try this:<UL><LI>'Start' > 'Control Panel' > 'Add or Remove Programs'<LI>On the left-hand side if the window, click the 'Set Program Access and Defaults' button<LI>Put the dot in the 'Custom' radio button and click the down double-arrow<LI>Under 'Choose a default e-mail program:', put the radio button in 'Outlook Express' and if you do not want to use Outlook for e-mail, you may also uncheck the box next to 'Enable access to this program' across from 'Outlook' and then click 'OK'[/list]However, oftentimes for your default mail client to stick, there are two places this setting has to be changed as just changing a setting in Outlook, Outlook Express or IE by itself will not suffice, so before you do the above, do this:<UL><LI>Open Outlook > 'Tools' > 'Options' > 'Other' tab<LI>Uncheck 'Make Outlook the default program for e-mail...' in the 'General' area, then 'Apply' > 'OK' and exit.<LI>Now open IE > 'Tools' > 'Internet Options' > 'Programs' tab<LI>Select 'Outlook Express' from the drop-down 'E-mail' box then 'Apply' > 'OK' and exit, then go to the above to set Outlook Express as the default program for your email.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •