Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Queensland, Australia
    Posts
    202
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Folder problem (XP SP1)

    I've just bought a new genealogy program (Rootsmagic)and being as keen as mustard installed the program then followed the instructions for importing my database (using a gedcom file) from my old genealogy program (Family Origins V8). Then my problem started.
    First I tried to save a gedcom file to the Rootsmagic folder and was advised "You don't have premission to save to this directory. See the administrator to obtain permission. Would you like to save to the Mydocuments folder".

    Well I am the administrator. I have a stand alone PC AMD 1900 with 520mb ram running Windows XP Home edition with Service Pack 1 installed.

    Anway I saved it to a Rootsmagic folder in the MyDocuments folder...No problem.

    Then opened Rootsmagic and created a database and went to File, Import Gedcom. Located the gedcom file in the My Documents folder and pressed OK. I didn't select any options on the next screen then pressed "Begin Import".

    Guess what? Roots Magic shut down.

    So I tried again (3 more times) and still it just closed down when I pressed "Begin Import" No files were imported.

    I'm assuming the import problem may possibly be associated with the folder problem so I thought I'd include it in this post.

    Any ideas would be appreciated.

    Thanks
    Dax


  2. #2
    Banned Member
    Join Date
    Jul 2002
    Location
    Newport Richey, Florida, USA
    Posts
    2,149
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Folder problem (XP SP1)

    Well i'm not sure if XP Home works the same because I use XP Pro. But with XP Pro , you Type in the word <font color=blue>Administrator</font color=blue> {for the user name} and then use your password { the password you created the first time before you could log on to your system. Then you will have Adminitrative rights.

  3. #3
    New Lounger
    Join Date
    Jan 2003
    Location
    Manchester, Gtr Manchester, England
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Folder problem (XP SP1)

    I have had lots of problems with user status and programs not specifically built for XP.
    On XP Home any user can have Admin or Limited status only. XP Pro (I believe) lets you set other intermediate levels like you can on systems like NT.
    I have ended up with all but trivial users (eg the cat!) set up as admin. Each user can still block access to folders from other users.
    Obviously you need to have Admin status to change another user upwards from Limited and the system should make sure at least one user has admin status.
    Don't know if this helps, but you are not alone! <img src=/S/2cents.gif border=0 alt=2cents width=15 height=15>

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Folder problem (XP SP1)

    <P ID="edit" class=small>(Edited by DaveA on 13-Feb-03 09:53. )</P>With the Windows XP Home version, the ONLY way to get to the "Administrator" account is to boot into the SAFE mode.

    Your account should HAVE admin permissions unless you changed things.

    I have not tried RootsMagic as of yet, but I do plan on it.

    Was this GECOM file made before the installion of RootsMagic?

    You will find that some programs do not like other programs invading their folders.

    <font color=red>Edit
    Just installed the Demo version and imported 10 defferent GEDCOM files, each from PAF, FTM or Legacy and had from 20 people to 3,000 in the different files. No problems what ever, all GEDCOM's were saved in the My Documnets folder. Can not make a GEDCOM file in the demo version of RootsMagic so I can not test that .</font color=red>

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  5. #5
    Lounger
    Join Date
    Nov 2001
    Location
    Long Island, NY
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Folder problem (XP SP1)

    You may need to take ownership of the drive. We had this problem in the office, and I'll try to remember the steps we took. First you have to go to Control Panel, then folder options. Under "view", unclick "use simple file sharing". Then you should open Explorer, highlight the icon for your C: drive (or whatever drive it is), right click, and then go to Properties. Under Properties, go to security, then click on Advanced, and then on the "owner" tab. There is a large box that says "change ownership to". In that box are the user names. Highlight your name, click on the option to replace owner on subcontainers and objects, and click OK. The computer will then take a while to change ownership on every file. Thereafter, you should have no problem. This also works for individual folders as well.

    Hope this works; hope it helps.

    Joel

  6. #6
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Queensland, Australia
    Posts
    202
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Folder problem (XP SP1)

    Thanks everyone for their replies.

    Cowboy & Joelw
    XP pro works differently to Home Edition and my User Account already shows me as the Computer Administer

    Mikew and DaveA, yes I already have Computer administrator rights. Dave I haven't booted into safe mode yet, will try when I log off (Yes unfortunately I'm still on a dial up connection, don't have access to broadband where I live in Australia).

    I don't think the problems with the CD as I loaded it onto another one of my PC's running W98 and I was able to place files in the Rootsmagic folder and import the gedcom file. Unfortunately for a range of reasons I can't use the other PC for my program on a permanent basis.

    If anyone has any other ideas I'm more then happy to try them
    Cheers
    Dax


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •