Results 1 to 5 of 5
  1. #1
    4 Star Lounger
    Join Date
    Jan 2003
    Location
    Central Florida, USA
    Posts
    505
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Error with mde but not mdb (2k)

    I have database that runs fine as an mdb. However, everytime I use the Tools>Database Utilities>Make mde file and then run one of the forms (and it only occurs on one specific form) I get the error "The expression On click you entered as the event property produced the following error: The command or action 'Save' isn't available now.
    * The expression may not result in the name of a macro, the name of a user-defined function, or [Event Procedure]
    * There may have been an error evaluating the function, event, or macro.

    The following is the code behind the save control on the form. (This works fine in the mdb with no errors, only get the error in the mde AAAAAAHHHHHH! ! ! ! !)

    Private Sub cmdSaveRecord_Click()
    DoCmd.RunCommand acCmdSave
    Me.AllowEdits = False
    cmdGotoFirstRecord.Enabled = True
    cmdGotoPreviousRecord.Enabled = True
    cmdGotoNextRecord.Enabled = True
    cmdGotoLastRecord.Enabled = True
    cmdAddRecord.Enabled = True
    cmdCloseForm.Enabled = True
    cmdEdit.Enabled = True
    End Sub

    In addition, I have compiled, decompiled and created the mde on two different workstations with the same results.

    Any ideas are greatly appreciated.

    Respectfully,
    kwvh

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Error with mde but not mdb (2k)

    Try DoCmd.RunCommand acCmdSave<font color=red>Record</font color=red> instead

    The expression you're using is trying to save the form object, and you can't do that in an mde.
    Charlotte

  3. #3
    4 Star Lounger
    Join Date
    Jan 2003
    Location
    Central Florida, USA
    Posts
    505
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: Error with mde but not mdb (2k)

    God Bless You! I owe you a lunch.

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Error with mde but not mdb (2k)

    <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15> It's a bit of a drive between California and Texas just for a light meal. I'll settle for a <img src=/S/thankyou.gif border=0 alt=thankyou width=40 height=15> until the next time I'm in the Lone Star State. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>
    Charlotte

  5. #5
    4 Star Lounger
    Join Date
    Jan 2003
    Location
    Central Florida, USA
    Posts
    505
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: Error with mde but not mdb (2k)

    Well, on the other hand, I may be in Santa Clara (Paramount's Great America) on business. Who knows, I may get there before you get to TX. Regardless, I thank you very much!

    Kwvh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •