Results 1 to 8 of 8
  1. #1
    3 Star Lounger
    Join Date
    Sep 2002
    Posts
    294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    97 to 2000 error ( 97 to 2000)

    We recently converted from access97 to access2000.

    Previously if i wanted to make a change to the database, i just opened it and changed it, but now, access2000 is insisting that the database is opened
    exclusively. Can i get around this ?

    Seems a backward step.

    any help much appreciated.

  2. #2
    Bronze Lounger
    Join Date
    Nov 2001
    Location
    Arlington, Virginia, USA
    Posts
    1,394
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Re: 97 to 2000 error ( 97 to 2000)

    If you are referring to being able to save changes to database objects such as forms or reports (as opposed to saving changes to records), recommend create shortcut to database with the "/excl" command line switch to open db in exclusive mode. Example of shortcut "target":

    "C:Program FilesMicrosoft OfficeOffice10MSACCESS.EXE" "C:ACCESSMYAPP.MDB" /excl

    Note when using command line switches you need to provide full path to Access executable file as well as the specific database (if secured db also need to specify path to workgroup file, and, optionally, username and password). If any spaces in path the quotes are required.

    HTH

  3. #3
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: 97 to 2000 error ( 97 to 2000)

    I presume you are talking about design changes in the database - i.e. changes to forms, reports or code. One of the major changes in Access 2000 was to set the database to exclusive before a design change is made. It is well publicized, and was caused by problems with corruption and with inadvertent loss of design changes with previous versions of Access. But you do also want to install SR-1 for sure - lots of important Access fixes in it.
    Wendell

  4. #4
    3 Star Lounger
    Join Date
    Sep 2002
    Posts
    294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 97 to 2000 error ( 97 to 2000)

    <P ID="edit" class=small>(Edited by charlotte on 03-Mar-03 20:59. to activate link)</P>Ok., I should have known better.....

    I wasn't quite sure what to search on, but this i *think* is the answer. so if anyone has anything to add feel free <img src=/S/crazy.gif border=0 alt=crazy width=15 height=15>

    http://support.microsoft.com/default.aspx?...kb;en-us;238258


    SYMPTOMS
    When you try to edit data in a multiuser Jet database or in a database that you have open more than once on your computer, you cannot modify the records, and the Record Locked icon is displayed to the left of the record in the table. This behavior occurs even when you have the database set for record-level locking and no one else is editing the same record.
    CAUSE
    The first instance of the multiuser Jet database was opened either by using a Windows shortcut or by double-clicking the *.mdb file in Windows Explorer. When Access 2000 opens a Jet database in these ways, the Jet database uses page-level locking instead of record-level locking.
    RESOLUTION
    To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

    To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:
    245025 OFF2000: How to Obtain and Install Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)

    To temporarily work around this problem, ensure that Microsoft Access uses the correct record or page locking setting. To do so, open Access first, and then use either the Open an existing file option in the startup Microsoft Access dialog box or the Open command on the File menu to open the database.
    STATUS
    Microsoft has confirmed that this is a problem in Microsoft Access 2000. This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.
    MORE INFORMATION
    The behavior described in the "Symptoms" section of this article is of particular concern under the following conditions:
    You have the Default record locking option set to Edited Record or to All Records.
    You want to open a database by using specific command-line switches.
    You are distributing an Access run-time solution.
    Although you cannot completely avoid this problem under these conditions, you may be able to moderate them by changing the locking strategy or by changing the startup procedure that you use for opening a database.

  5. #5
    3 Star Lounger
    Join Date
    Sep 2002
    Posts
    294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 97 to 2000 error ( 97 to 2000)

    From what i understand here, WendellB is saying that my database which is live, can no longer really be altered all the time its up and running, ...

    Is there an easy solution here, ? The only thing i can think of , is to copy it. amend it, test it. bring the db down, and then add the new queries.

    It really looks like Micro$oft screwed up again. (yea, ok, you say but you get better file security .. bah humbug i say, our db's are still corrupting just as much as when we were on A97, if not more !)

    Is there anyway to turn this 'feature' off?


    I tried the option of initially opening the first instance of the database, using 'File' > Open...
    it seemed to work initially, but then stopped working, (i presume because someone else logged into the database?)
    Maybe i did it wrong?

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: 97 to 2000 error ( 97 to 2000)

    Whether you or I like it or not doesn't really matter - you *must* have exclusive access to a version 2000 or 2002 database if you want to modify and save the design of database objects, and there is no backdoor or option to turn it off. So you can't modify the design of database objects as long as other users are active - period.

    You can check whether the database is in use by inspecting the folder it is in - while the database is in use, there is a file with the same name as the database but with extension .ldb. It is deleted automatically when the last user closes the database. If you work with a front end and back end database, both will have an .ldb file as long as users are active.

    When you select File/Open..., you have the option to open a database exclusively. If you do that, others won't be able to open the database at all - they'll get a message that the database has been opened exclusively by (user name). If you omit to set this option, others may open the database too, thereby taking away your right to modify and save database objects.

  7. #7
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: 97 to 2000 error ( 97 to 2000)

    <<From what i understand here, WendellB is saying that my database which is live, can no longer really be altered all the time its up and running, ...

    Is there an easy solution here, ? The only thing i can think of , is to copy it. amend it, test it. bring the db down, and then add the new queries. >>


    For forms, reports and code that is true - you can still create queries and make data changes of course. Access 97 had a very bad habit of mangling forms in particular when you tried to put a design change into a form that was open, and the user with the open form had applied a filter. It would then save the old design over the top of the new one, and changes you were sure you had deployed were suddenly gone.

    Our solution is to deploy a copy of the front-end to each workstation, and then update the copy if necessary the next time the database is started - we have a rather powerful utility we use to do that, and FMS has just announced a somewhat similar tool. In any event you definitely don't want to do development work on a live copy of the database - that's like playing Russian Roulette with five chambers loaded as opposed to one.

    <<It really looks like Micro$oft screwed up again. (yea, ok, you say but you get better file security .. bah humbug i say, our db's are still corrupting just as much as when we were on A97, if not more !)

    Is there anyway to turn this 'feature' off? >>


    I think most people who have been through an upgrade from 97 to 2000 would disagree with you strongly - we saw a pretty dramatic reduction in corruption when we moved from 97 to 2000 and implemented putting the front-end on the workstation. And no, there isn't any way of turning that feature off - as I understand it, it's a part of the Jet 4.0 database engine.

    As to the opening of the file exclusively, as long as you open it that way, nobody else should be able to open the database. If you are using a shortcut to do that you may have a problem with the shortcut.
    Wendell

  8. #8
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: 97 to 2000 error ( 97 to 2000)

    In addition to the comments Hans and Wendell have made, I'll add my own experience. I developed and was maintaining multiple Access 97 databases which were used by from 5 to 15 people at once and trying to make changes on the fly. I would work late, finish and save the changes ... and come in the next morning to find them gone! They were gone because one of the users had not exited the database before they left for the day. I couldn't tell that and Access 97 didn't complain, but when that user closed their session, it overwrote the changes I had made. I stood up and cheered when Microsoft made that impossible in the 2000 release of Access. <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •