Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2001
    Location
    Kent, UK
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    #Name? in Access 2000 running Windows 2000

    We have a Access database that a group of us share. We have been using it with Access 2000, running under Windows 98 SE without problem for a couple of years.

    I have recently aquired a new machine running Windows 2000 and installed Access 2000. Now everytime I access this Access database it displays '#Name?' in the field on the form that has '=Date()' as the default value. I also have a message displayed that says 'Function is not available in expressions in table-level validation expressions'. If I enter the date in this field manually then it is OK, but when create a new record I get the same problem again!

    It must be something to do with Windows 2000, as it works fine under Windows 98SE. I've checked the date format in Win 2000, and checked that the settings in Access 2000 are the same as the 98SE machines. Any ideas anyone ?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: #Name? in Access 2000 running Windows 2000

    This is almost certainly a problem with references. Some object libraries are stored in a different path under Win2000 compared to Win98.

    Open the database with the Shift key held down.
    Switch to the Visual Basic Editor (Alt+F11).
    Select Tools/References...
    Probably, one or more references start with MISSING.
    Click each of these in turn, note what the reference is, then uncheck the box.
    Click OK to close the References dialog.
    Try to compile the project (Debug menu).
    If you get error messages about unknown types, you will have to find the correct reference and set it.
    Of course, there may also be "normal" programming errors that went undetected until you try to compile <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

  3. #3
    New Lounger
    Join Date
    Dec 2001
    Location
    Kent, UK
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: #Name? in Access 2000 running Windows 2000

    I did what you said, but could not find any 'missing' references.
    BUT the problem is now fixed, it turned out that the database was still in Access 97 format (some of our users in the group still use Access 97). Although we had no problems running this Access 97 database with Access 2000 under Windows 98SE, it obviously causes problems under Windows 2000. Updating the database to Access 2000 format resolved the problem.

    Anyway, thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •