Results 1 to 4 of 4
  1. #1
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Report Problem (Access 2000 )

    I attach a file with a report whose behaviour I don't understand.
    The database is about Horse Trail Rides, and I want a report listing rides conducted between selected dates.

    I have a form with two text boxes to set the dates, a query that uses the form for parameters, and a report that was built from the query using the report wizard.

    The query works as expected. The report looks OK in design view, but when I go to preview mode all pages are blank. If I click the "go to last page" button at the foot of the report, it takes a while and eventually stops at page "2520524".
    ***********
    I have set the format of the date text boxes to mm - yyyy so that only months and years are displayed, and reporting is always for whole months. I also want the whole of the finishing month included in the report, so the query includes dates up to the end of that month. As I said before the query works Ok, and return the correct data. The problem is only with the report.

    I was able to get this to work by reformatting the text boxes to dd/mmm/yyyy and changing the query to just the dates as entered, but I am still puzzled why the original did not work.
    Attached Files Attached Files
    Regards
    John



  2. #2
    Lounger
    Join Date
    Dec 2002
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report Problem (Access 2000 )

    Check the margins of the report.

  3. #3
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Report Problem (Access 2000 )

    Hi John

    That's a weird problem you have, it does not happen on my machine. All I get is a 1 page report. The format of the 2 text boxes is mmm - yyyy.

    Pat

  4. #4
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Report Problem (Access 2000 )

    Thanks

    The margins fixed it. They were being set at about 120 mm left and right, and I think 130 mm top and bottom.

    Why would it set those margins? I rebuilt the report several times, several different ways, in both Access 2000 and Access97 and it happened each time.
    Regards
    John



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •